Hi,
I'm trying to register my new SLES12 VM, but it happens I can't.
Whenever I give the SUSEConnect command I get the following ruby error:

SUSEConnect -help
/usr/lib64/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'suse-connect' (= 0.2.14) among 65 total gem(s) (Gem::LoadError)
from /usr/lib64/ruby/2.1.0/rubygems/dependency.rb:309:in `to_spec'
from /usr/lib64/ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:53:in `gem'
from /usr/sbin/SUSEConnect:22:in `<main>'


I have to say that I had to install the old 1.8.7 version of ruby to let an old web site work.
but it is in /usr/local/rvm/... and I think it should not interfere with SUSEConnect, but who knows?

Can you please help me?
Thanks fronm italy,
Emanuele