Hello Forum Users,


I have Installation problems with SLES 12, Raid 1, UEFI and or not Secure Boot.


I have installed the System more times with the settings above.

The installation was without errors, but after that my GUI worked not perfect.

I can't work with the highest resolution, and the options worked not normal.

Additonal i got this error:

HTML Code:
EFI: Problem loading in-kernel x.509 certificate (-129)

EFI: Problem loading in-kernel x.509 certificate (-74)
and my gdisk output after Installation was following:


HTML Code:
Found invalid GPT and valid MBR; converting MBR to GPT format
in memory. THIS OPERATION IS POTENTIALLY DESTRUCTIVE! Exit by 
typing 'q' if you don't want to convert your MBR partitions 
to GPT format!

Then I switched off Secure Boot and the errors was away (still boot with the first HDD).

My both boot partitions are with a valid GPT and the identifier ef00 (before and after the Installation). This one I build with a LIVE CD (UEFI) or with the Installer of the SLES DVD (UEFI).

But if I copied my UEFI start partition (sda1) with dd to sdb1 the GUI error comes again and gdisk show a invalid GPT.

It can't be a secure boot problem only because it was disabled and just by the copy of sda1 to sdb1 the error comes again. I have repeat the Installation (without Secure Boot), and before copying (the boot partitions) the Graphic works normal.


Code:
Secure Boot on:	 errors (GUI, gdisk and EFI: Problem loading in-kernel x.509 certificate errors)

Secure Boot off and one HDD:  no errors

Secure Boot off and copying the boot partitions:  errors (GUI and gdisk errors)


Thank you for reading!