Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: SLE12: No remote installation (vnc or ssh) possible

Hybrid View

  1. #1
    Bernd NNTP User

    SLE12: No remote installation (vnc or ssh) possible

    Hi,

    I try to install a SLE12-Server (x64) via VNC as a VMware-VM. NIC is
    attached.

    Used Boot-Options: hostip=192.168.1.1/24 gateway=192.168.1.254 vnc=1
    vncpassword=12345678

    After this install begins but shows me the graphical License-Agreement
    insteed the VNC-Connection infos.

    There is no possibility to connect to the host via vnc, nor ping.

    Same issue during install via ssh.

    Any hints?

    Bye

    Bernd


  2. #2
    Bernd NNTP User

    Re: SLE12: No remote installation (vnc or ssh) possible

    I check it by an installation as a KVM-guest. Same behavior! It seems that
    it is not possible to install SLE12 via VNC. But the documentation
    describted it exactly as I have try it.

    Bernd


  3. #3

    Re: SLE12: No remote installation (vnc or ssh) possible

    On 24/11/2015 16:26, Bernd wrote:

    > I try to install a SLE12-Server (x64) via VNC as a VMware-VM. NIC is
    > attached.
    >
    > Used Boot-Options: hostip=192.168.1.1/24 gateway=192.168.1.254 vnc=1
    > vncpassword=12345678
    >
    > After this install begins but shows me the graphical License-Agreement
    > insteed the VNC-Connection infos.
    >
    > There is no possibility to connect to the host via vnc, nor ping.
    >
    > Same issue during install via ssh.
    >
    > Any hints?


    Hmm I just tried starting a virtual install of SLES12 using exactly the
    same boot options (okay so IP address was different to suit my setup but
    otherwise the same) and I get the prompt to switch to a VNC client or
    web browser to continue the install. When I then connect to the server
    via RealVNC Viewer to xx.xx.xx.xx:1 I then see the Language, Keyboard
    and License Agreement.

    Note that occasionally during the initial install I do get prompted to
    retry accessing the installation medium but when I do so the bootstrap
    install works and hands over to VNC.

    I'm booting the VM from DVD ISO and also setting the language (English
    UK), video mode (Text Mode), and source (HTTP) before starting the install.

    HTH.
    --
    Simon
    SUSE Knowledge Partner

    ------------------------------------------------------------------------
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below. Thanks.
    ------------------------------------------------------------------------

  4. #4
    Bernd NNTP User

    Re: SLE12: No remote installation (vnc or ssh) possible

    Simon Flood wrote on Dienstag, 24. November 2015 18:19 in
    suse.support.server.install-boot :

    > Hmm I just tried starting a virtual install of SLES12 using exactly the
    > same boot options (okay so IP address was different to suit my setup but
    > otherwise the same) and I get the prompt to switch to a VNC client or
    > web browser to continue the install.

    Yes that is the way I expected und know from the earlier version (SLE11 ...)

    > When I then connect to the server via RealVNC Viewer to xx.xx.xx.xx:1

    This is not able for me on both(!) enviroments. Not net connection, no ping.

    > I then see the Language, Keyboard and License Agreement.

    This out comes on the screen of the VM


    (...)
    > I'm booting the VM from DVD ISO and also setting the language (English
    > UK), video mode (Text Mode), and source (HTTP) before starting the
    > install.

    OK, i use a DVD image bound to an DVD from the VM

    I check this with source via http.

    Cloud you check the ssh256sum?
    Here it is:
    58086fca0441b1d44c7a51c5ee64e1bd4365466fcee48ec92c 4f39d07739aeed SLE-12-
    Server-DVD-x86_64-GM-DVD1.iso


  5. #5

    Re: SLE12: No remote installation (vnc or ssh) possible

    On 24/11/2015 17:29, Bernd wrote:

    > Yes that is the way I expected und know from the earlier version (SLE11 ...)


    I'll admit I hadn't tried it with SLES12 (even during closed beta) and
    having found something by IBM which also suggested it doesn't work (as
    documented by SUSE) I wasn't then expecting it to work for me but it did.

    > This is not able for me on both(!) enviroments. Not net connection, no ping.


    I tried this with VMware Player 7. Which VMware product are you using?

    > This out comes on the screen of the VM


    I think I recall something about ESXi blocking the VNC port but then I
    would expect that VM to not know that so still hand over to VNC to
    continue the install and for you then not to be able to connect via VNC
    (leaving install in limbo state).

    > OK, i use a DVD image bound to an DVD from the VM
    >
    > I check this with source via http.
    >
    > Cloud you check the ssh256sum?
    > Here it is:
    > 58086fca0441b1d44c7a51c5ee64e1bd4365466fcee48ec92c 4f39d07739aeed SLE-12-
    > Server-DVD-x86_64-GM-DVD1.iso


    That's what I have and matches my downloaded ISO as does the MD5
    checksum 64b50e62b9c5b603d83fe128adb7dc6c.

    HTH.
    --
    Simon
    SUSE Knowledge Partner

    ------------------------------------------------------------------------
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below. Thanks.
    ------------------------------------------------------------------------

  6. #6
    Bernd NNTP User

    Re: SLE12: No remote installation (vnc or ssh) possible

    Simon Flood wrote on Dienstag, 24. November 2015 19:09 in
    suse.support.server.install-boot :

    > On 24/11/2015 17:29, Bernd wrote:
    >
    >> Yes that is the way I expected und know from the earlier version (SLE11
    >> ...)

    (...)
    >
    > I tried this with VMware Player 7. Which VMware product are you using?

    I try ESX and KVM

    (...)
    > I think I recall something about ESXi blocking the VNC port but then I
    > would expect that VM to not know that so still hand over to VNC to
    > continue the install and for you then not to be able to connect via VNC
    > (leaving install in limbo state).

    Hmm, but this occurs even if I choose install via SSH insteed of VNC. So I
    think there is no port blocked.
    >
    >> OK, i use a DVD image bound to an DVD from the VM
    >>
    >> I check this with source via http.

    This make no difference ...
    >>
    >> Cloud you check the ssh256sum?

    (...)
    > That's what I have and matches my downloaded ISO as does the MD5
    > checksum 64b50e62b9c5b603d83fe128adb7dc6c.

    OK, so we use the same source.

    Probably there is a issue with the NIC (and the timing). Sometimes the
    installer redirects me to the ASCII menue and display a message like "Source
    not found". Even if I use DVD as source! Then I configure the network in
    this ASCII installer menue and I have to choose between a RedHat virtual
    Device and a virtual Ethernet Device. So I have change die VM-Setting to
    e1000. (And choose since than virtual Ethernet device) It seems that there
    is some struggeling with Wicked and so on. Sometimes(!) I get the VNC if I
    configure the network in the ASCII installer. But I have to insert a DNS-
    Server and a search domain even if I do not need this info.



  7. #7
    Bernd NNTP User

    Re: SLE12: No remote installation (vnc or ssh) possible

    New tests:

    Install source at http: and e1000 NIC: OK

    Install source at DVD and e1000 NIC: Fail! End up in graphical install on
    the hosts itself.

    Install source at http: and virtio NIC (KVM):
    Basic tasks run but the result screen (on which you get the hints to use
    vnc) is only visible parts of a second. Then it throw an Error and shows
    ASCII install screen. Then I used the option 'Installation' and do not
    change any item. Install rerun and finished at the vnc info screen -
    perfect!
    I assume that there is a problem because when I configure network separatly
    on the ASCII screen I have to choose between RedHat and eth0 (see my
    previous posting)

    Install source at DVD and virtio NIC (KVM):
    Shows a ASCII menu with the two possible network devices:
    -Red Hat virtio network device
    -eth0 : Virtio Ethernet Card 0

    I choose eth0, it try to send DHCP request. (There will be no answer,
    because there is no DHCP in that segment) It thows an error an show a ASCII
    menue where I can chosse the language. Then it ends up in the graphical
    installer at the host itself.

    (If I choose the RedHat module it fail an say: No such Module.)

    Maybe there is some hassle with the open-vm-tools?

    Bye

    Bernd

  8. #8

    Re: SLE12: No remote installation (vnc or ssh) possible

    On 25/11/2015 10:49, Bernd wrote:

    > New tests:
    >
    > Install source at http: and e1000 NIC: OK
    >
    > Install source at DVD and e1000 NIC: Fail! End up in graphical install on
    > the hosts itself.
    >
    > Install source at http: and virtio NIC (KVM):
    > Basic tasks run but the result screen (on which you get the hints to use
    > vnc) is only visible parts of a second. Then it throw an Error and shows
    > ASCII install screen. Then I used the option 'Installation' and do not
    > change any item. Install rerun and finished at the vnc info screen -
    > perfect!
    > I assume that there is a problem because when I configure network separatly
    > on the ASCII screen I have to choose between RedHat and eth0 (see my
    > previous posting)
    >
    > Install source at DVD and virtio NIC (KVM):
    > Shows a ASCII menu with the two possible network devices:
    > -Red Hat virtio network device
    > -eth0 : Virtio Ethernet Card 0
    >
    > I choose eth0, it try to send DHCP request. (There will be no answer,
    > because there is no DHCP in that segment) It thows an error an show a ASCII
    > menue where I can chosse the language. Then it ends up in the graphical
    > installer at the host itself.
    >
    > (If I choose the RedHat module it fail an say: No such Module.)
    >
    > Maybe there is some hassle with the open-vm-tools?


    Except open-vm-tools won't have taken effect yet.

    Whilst I specified the IP address, network mask, and gateway address I
    didn't specify the DNS address but that must have been figured out as I
    referenced my HTTP server by name rather than address. Can you try
    adding "netwait=30" to your boot options to wait 30 seconds for
    networking to come up before continuing the install.

    HTH.
    --
    Simon
    SUSE Knowledge Partner

    ------------------------------------------------------------------------
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below. Thanks.
    ------------------------------------------------------------------------

  9. #9
    Bernd NNTP User

    Re: SLE12: No remote installation (vnc or ssh) possible

    Simon Flood wrote on Mittwoch, 25. November 2015 13:06 in
    suse.support.server.install-boot :

    > On 25/11/2015 10:49, Bernd wrote:
    >
    >> New tests:
    >>
    >> Install source at http: and e1000 NIC: OK
    >>
    >> Install source at DVD and e1000 NIC: Fail! End up in graphical install on
    >> the hosts itself.
    >>
    >> Install source at http: and virtio NIC (KVM):
    >> Basic tasks run but the result screen (on which you get the hints to use
    >> vnc) is only visible parts of a second. Then it throw an Error and shows
    >> ASCII install screen. Then I used the option 'Installation' and do not
    >> change any item. Install rerun and finished at the vnc info screen -
    >> perfect!
    >> I assume that there is a problem because when I configure network
    >> separatly on the ASCII screen I have to choose between RedHat and eth0
    >> (see my previous posting)
    >>
    >> Install source at DVD and virtio NIC (KVM):
    >> Shows a ASCII menu with the two possible network devices:
    >> -Red Hat virtio network device
    >> -eth0 : Virtio Ethernet Card 0
    >>
    >> I choose eth0, it try to send DHCP request. (There will be no answer,
    >> because there is no DHCP in that segment) It thows an error an show a
    >> ASCII menue where I can chosse the language. Then it ends up in the
    >> graphical installer at the host itself.
    >>
    >> (If I choose the RedHat module it fail an say: No such Module.)
    >>
    >> Maybe there is some hassle with the open-vm-tools?

    >
    > Except open-vm-tools won't have taken effect yet.

    (...)
    > Can you try adding "netwait=30" to your boot options to wait 30 seconds
    > for networking to come up before continuing the install.
    >

    Yepp, tested. But this makes no difference. Same behavior. But wait now 30
    seconds for DHCP ... :-\



    Are there more bootoptions? Like use only IPv4 or similar?


  10. #10

    Re: SLE12: No remote installation (vnc or ssh) possible

    On 25/11/2015 14:23, Bernd wrote:

    > Yepp, tested. But this makes no difference. Same behavior. But wait now 30
    > seconds for DHCP ... :-\


    Hmm.

    > Are there more bootoptions? Like use only IPv4 or similar?


    Yes:

    ipv4only=1 # enable only IPv4 during installation
    ipv6only=1 # enable only IPv6 during installation
    ipv4=[1|0] # enable/disable IPv4
    ipv6=[1|0] # enable/disable IPv6

    You can combine one of the first two with one of the last two - for
    installs using private IP addresses I use "ipv4only=1 ipv6=0" to not use
    IPv6 during the install or have it configured post-install.

    HTH.
    --
    Simon
    SUSE Knowledge Partner

    ------------------------------------------------------------------------
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below. Thanks.
    ------------------------------------------------------------------------

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •