Quote Originally Posted by tgm_its View Post

I don't know if you have solved this yet, but setting
"net.ipv4.conf.all.rp_filter = 0" in /etc/sysctl.conf solved it for me.
I also had an issue that turned out to be ICMP redirects. In addition to rp_filter setting above, I set the following to disallow redirects, which is the recommended setting if you're not using your linux server as a router:

# /etc/sysctl.conf
net.ipv4.conf.all.accept_redirects = 0
net.ipv4.conf.all.secure_redirects = 0
net.ipv4.conf.all.send_redirects = 0
net.ipv4.conf.default.accept_redirects = 0
net.ipv4.conf.default.secure_redirects = 0
net.ipv4.conf.default.send_redirects = 0
FYI, redirect messages were sent from my router whenever a leg of our MPLS went down. I could see the redirect stored in cache on my host This was a redirect for a route between two specific hosts: to

$ ip route list cache match via dev eth1  src
    cache <redirected>  ipid 0x3f1a rtt 15ms rttvar 11ms ssthresh 61 cwnd 61
Doing ip route flush cache did not fix the issue due to some kind of bug. The cache apparently clears itself after 10 minutes, but only if you're not attempting any communication between the two specific hosts.

I had to reboot to clear the cache. I'm hoping the sysctl settings above will work - haven't had any network issues to be able to test it, and haven't tried any artificial tests.