From where did you find the KDE packages in the first place?

I'm 99% sure you should not be doing this. KDE was pulled from SLE 12,
but if you want to use it on very similar code you could check out
openSUSE 42.1 (Leap) which is based on the SLE 12 SP1 codebase, though the
obvious caveat there is that it is not SUSE Linux Enterprise so support is
very different, both from the vendor (openSUSE, not SUSE) and likely with
third parties.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...