A few months ago I fully patched SLES 11 SP4 (running kdm) - back when RealVNC 5.1 was shiny and new. I discovered that just attempting to connect to Linux - that is, without even typing any login details - will repeatably crash Linux (not just kdm)! This is indeed very disturbing.

Fortunately, RealVNC 4.1.3 behaved normally with SLES, so I just kept using that. (BTW, RealVNC 5.1 worked normally with OpenSUSE 13.2 - also running kdm.)

Skip forward a few months. I just applied all the latest SLES 11 SP4 (still running kdm) patches and tried the even newer RealVNC 5.3 - the result is the same as before.

Google tells me that nobody else on the planet has had this problem, so I tried switching to gdm. Suddenly, life is beautiful again.

RealVNC 4.3.1 : OpenSUSE/kdm works normally, SLES/kdm works normally, SLES/gdm works normally
RealVNC 5.3 : OpenSUSE/kdm works normally, SLES/kdm crashes, SLES/gdm works normally

Also, logging in on the (virtual) VMWare "console" always works normally.

I will post some /var/log/messages and /var/log/kdm.log details as a follow-up.

Does anyone have any idea what could cause this behavior?