Problem: wlan can't be activated in the NetworkManager icon of the task bar, the wlan checkbox is grey and untouchable. LAN is working fine.

Maybe there is a hint to a configuration issue in /etc/NetworkManager/NetworkManager.conf, because manually changing the content to "enabled=true" in the section for wireless doesn't have any effect and has disappeared after reboot, whether or not I fire SuSEconfig. Hardware information doesn't show any extraordinary content.

OS SLED11 SP4
Some output of some commands and some content of some files:

$ /sbin/lspci -nnk |grep -A3 Network
07:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
Subsystem: Hewlett-Packard Company Device [103c:1461]
Kernel driver in use: ath9k
Kernel modules: ath9k

$ dmesg
...
[ 10.105745] ath9k 0000:07:00.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
[ 10.105938] ath9k 0000:07:00.0: setting latency timer to 64
[ 10.155391] ath: EEPROM regdomain: 0x60
[ 10.155395] ath: EEPROM indicates we should expect a direct regpair map
[ 10.155401] ath: Country alpha2 being used: 00
[ 10.155404] ath: Regpair used: 0x60
[ 10.198696] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000
:00:01.1/sound/card0/input10
[ 10.199217] HDA Intel 0000:00:14.2: PCI INT A -> GSI 16 (level, low) -> IRQ 1
6
[ 10.199340] ALSA hda_intel.c:2952 Using LPIB position fix
[ 10.223893] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 10.224463] Registered led device: ath9k-phy0
[ 10.224471] ieee80211 phy0: Atheros AR9285 Rev:2 mem=0xf8420000, irq=23
...

$ grep NETWORKMANAGER /etc/sysconfig/network/config
NETWORKMANAGER=yes

$ cat /etc/NetworkManager/NetworkManager.conf
[wireless]
enabled=false