sorry about the delay.

So did the system originally come with SLED, or was it running windows?

If you reboot and press F10 to go to the BIOS and disable both the
bluetooth and wireless save/exit and restart the system and let it boot
to SLED, is the light now amber, and what is the output from rfkill?

Then restart the computer, press F10 again and re-enable the wireless
and bluetooth and save/exit and let the computer start up, does it all
The BIOS main menue doesn't allow to select the items for WLAN or Bluetooth and change their set-up. HP diagnostic log contains no errors.

HP have some special drivers for both wireless and bluetooth, not sure
if available for that model and SLE 12, you would need to contact HP
I'm working with SLE11 SP4.

Today I tried to manually start wlan0, because I hoped to get more information what is going wrong. Therefore in YaST I changed network configuration from NetworkManager method to ifup, then rebooted.

hpc:~ # iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
After reboot the reply was the same. I tried "ifstatus" and "ifup":

hpc:~ # ifstatus wlan0
    wlan0     device: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
DHCP4 client NOT running
DHCP6 client (dhclient6) is running
. . . but is still waiting for data
    wlan0     is down

hpc:~ # ifup wlan0
    wlan0     device: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
    wlan0     starting wpa_supplicant
Could not set interface wlan0 flags: Unknown error 132
Could not set interface 'wlan0' UP
Failed to initialize driver interface
ELOOP: remaining socket: sock=4 eloop_data=0x80f1970 user_data=0x80f1690 handler=0x80b7860
DHCP6 client is already running on wlan0
RTNETLINK answers: Unknown error 132
Starting DHCP4 client on wlan0. .  
    wlan0     DHCP4 client NOT running
    wlan0     DHCP6 continues in background
RTNETLINK answers: Unknown error 132
Cannot enable interface wlan0.
interface wlan0 is not up
To check if there might be a driver problem I ran "wpa_supplicant -h"

Here are some lines of the reply

wpa_supplicant v0.7.1
Copyright (c) 2003-2010, Jouni Malinen <j@w1.fi> and contributors
  wext = Linux wireless extensions (generic)
  nl80211 = Linux nl80211/cfg80211
  hostap = Host AP driver (Intersil Prism2/2.5/3)
  atmel = ATMEL AT76C5XXx (USB, PCMCIA)
  ndiswrapper = Linux ndiswrapper (deprecated; use wext)
  wired = Wired Ethernet driver
  ralink = Ralink Wireless Client driver
Shouldn't there be a driver "ath9k" or should "wext" do the job? By the way, a configuration file "/etc/wpa_supplicant.conf" does not exist.