Test system with SLED12 and SLE12-SDK. Migration with "zypper migrate"
fails with following output:

# zypper migration

Executing 'zypper refresh'

Repository 'SLED12-12-0' ist aktuell.


Repository 'SLE-12-GA-Desktop-AMD-Driver' ist aktuell.


Repository 'SLE-12-GA-Desktop-NVIDIA-Driver' ist aktuell.


Repository 'SLED12-Pool' ist aktuell.


Repository 'SLED12-Updates' ist aktuell.


Repository 'SLE-SDK12-Pool' ist aktuell.


Repository 'SLE-SDK12-Updates' ist aktuell.


Alle Repositories wurden aktualisiert.

Executing 'zypper --no-refresh patch-check --updatestack-only'

Daten des Repositories laden ...
Installierte Pakete lesen ...
0 Patches benötigt (0 Sicherheits-Patches)

SUSE::Connect::ApiError: Multiple base products found: ["SUSE Linux
Enterprise Desktop 12 x86_64", "SUSE Linux Enterprise Desktop 12 SP1
x86_64"]
'/usr/lib/zypper/commands/zypper-migration' exited with status 1


This is a test system. I can just erase it and start from scratch. The
product "SUSE Linux Enterprise Desktop 12 SP1 x86_64" is most likely
from an old try to upgrade. But then I am not able to get rid of it. And
it does not show up as an installed product:

# zypper products -i
Dienst 'SUSE_Linux_Enterprise_Desktop_12_x86_64' wird aktualisiert.
Dienst 'SUSE_Linux_Enterprise_Software_Development_Kit_12 _x86_64' wird
aktualisiert.
Daten des Repositories laden ...
Installierte Pakete lesen ...
S | Repository | Interner Name | Name
| Version | Arch | Ist Basis
--+------------+---------------+---------------------------------------------------+---------+--------+----------
i | @System | sle-sdk | SUSE Linux Enterprise Software
Development Kit 12 | 12-0 | x86_64 | Nein
i | @System | SLED | SUSE Linux Enterprise Desktop 12
| 12-0 | x86_64 | Ja

Any ideas how to proceed, Other than starting with a fresh installation :-)

Günther