Hello, All:

I've just inherited a SLED11-SP1 system and I'm attempting to update the one of the installed packages - MozillaFirefox. However, I'm afraid that I'm not understanding zypper properly:

Code:
genesco1:~ # zypper search Firefox
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...

S | Name                                 | Summary                                                  | Type      
--+--------------------------------------+----------------------------------------------------------+-----------
i | MozillaFirefox                       | Mozilla Firefox Web Browser                              | package   
  | MozillaFirefox                       | Mozilla Firefox Web Browser                              | srcpackage
i | MozillaFirefox-branding-SLED         | SLED branding of MozillaFirefox                          | package   
  | MozillaFirefox-branding-SLED         | SLED branding of MozillaFirefox                          | srcpackage
i | MozillaFirefox-translations          | Translations for MozillaFirefox                          | package   
i | beagle-firefox                       | Firefox Plugin for the Desktop search application beagle | package   
  | mhtml-firefox                        | Provides Firefox with MHTML web archive compatibility    | package   
  | mhtml-firefox                        | Provides Firefox with MHTML web archive compatibility    | srcpackage
i | sledsp1-MozillaFirefox               | Security update for Mozilla Firefox                      | patch     
i | sledsp1-MozillaFirefox-branding-SLED | Recommended update for MozillaFirefox-branding-SLED      | patch     
i | sledsp1-firefox-10                   | Security update for MozillaFirefox                       | patch     
i | sledsp1-firefox-201204               | Security update for Mozilla Firefox                      | patch     
i | sledsp1-firefox-201207               | Security update for Mozilla Firefox                      | patch     
i | sledsp1-firefox36upgrade             | Recommended update for Mozilla Firefox                   | patch     
  | sledsp1-mhtml-firefox                | Recommended update for mhtml-firefox                     | patch     
genesco1:~ # zypper update MozillaFirefox
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...
No update candidate for 'MozillaFirefox'.
Resolving package dependencies...

Nothing to do.
The user wants Mozilla Firefox upgraded from Version 10.0.6 to Version 31.3.0 but Zypper seems to be telling me that there is not an upgrade available.

Am I understanding that correctly?