Quote Originally Posted by smflood View Post
Since you're on SLED11 SP1 you'll first need to upgrade to SLES11 SP2 and then to SLED11 SP3 before you can get to SLED11 SP4... I'd therefore suggest upgrading to SLED11 SP2 but before upgrading to SLED11 SP3 and SLED11 SP4 you lock the MozillaFirefox package. You'd then need to install the latest Firefox ESR 31 update for SLED11 SP3 before then upgrading to SLED11 SP4.
That seems very straight-forward, Simon! But I'm a complete noob to zypper and SuSE. So far I haven't found any zypper tutorials that illustrate how to upgrade to a SP-level; how to lock packages, or; how to apply patches. Can you point me in the direction of a good tutorial?