Hello all!,

I try use the yast mail on SLED 12 SP1, but the options for configuration is not complete.

I want configure manually postfix (by example http://serverfault.com/questions/521...-using-postfix), but i receive some problems, this occur only with SLES because, i use RedHat Enterprise Linux 6.7 for my weblog and postfix operate OK.

These are my actual errors:

Code:
maudevsled12:/var/log # tail -F mail                        
2016-03-16T14:17:17.755086-06:00 maudevsled12 postfix/smtp[11253]: connect to smtp.gmail.com[2607:f8b0:4003:c06::6d]:587: Network is unreachable
2016-03-16T14:17:17.968024-06:00 maudevsled12 postfix/smtp[11253]: D8A894BD68: to=<mauricio.martinez-garcia@hpe.com>, relay=smtp.gmail.com[64.233.160.109]:587, delay=1476, delays=1475/1/0.24/0, dsn=4.7.5, status=deferred (TLS is required, but our TLS engine is unavailable)
2016-03-16T14:17:18.090549-06:00 maudevsled12 postfix/smtp[11253]: 800D14BDFE: TLS is required, but our TLS engine is unavailable
2016-03-16T14:17:18.090836-06:00 maudevsled12 postfix/smtp[11253]: connect to smtp.gmail.com[2607:f8b0:4003:c06::6d]:587: Network is 
unreachable
2016-03-16T14:17:18.312470-06:00 maudevsled12 postfix/smtp[11253]: 800D14BDFE: to=<mauricio.martinez-garcia@hpe.com>, relay=smtp.gmail.com[64.233.160.109]:587, delay=517, delays=515/1.3/0.29/0, dsn=4.7.5, status=deferred (TLS is required, but our TLS engine is unavailable)
2016-03-16T14:17:18.642646-06:00 maudevsled12 postfix/smtp[11254]: warning: connect to private/tlsmgr: Connection refused
2016-03-16T14:17:18.642970-06:00 maudevsled12 postfix/smtp[11254]: warning: problem talking to server private/tlsmgr: Connection refused
2016-03-16T14:17:18.643183-06:00 maudevsled12 postfix/smtp[11254]: warning: no entropy for TLS key generation: disabling TLS support
2016-03-16T14:19:02.416954-06:00 maudevsled12 postfix/scache[11258]: statistics: start interval Mar 16 14:17:17
2016-03-16T14:19:02.417160-06:00 maudevsled12 postfix/scache[11258]: statistics: domain lookup hits=0 miss=1 success=0%



I see, that the normal files not exist in SLED in comparison of RHN. by example: /etc/postfix/tls_policy

I want configure with this installation, because if try uninstall the default postfix zypper or yast want uninstall a lot of applications.





Code:
maudevsled12:/var/log # zypper remove postfix postfix-devel
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...
Resolviendo dependencias...

Los siguientes 30 paquetes van a ser ELIMINADOS:
  amavisd-new apache2-mod_php5 google-chrome-stable lsb lsb5-core lsb5-desktop php5 php5-ctype php5-curl php5-dom php5-gd php5-gettext php5-iconv php5-json php5-mbstring php5-mysql
  php5-odbc php5-pdo php5-pgsql php5-readline php5-soap php5-sockets php5-sqlite php5-tokenizer php5-xmlreader php5-xmlwriter php5-zlib postfix postfix-devel postfix-mysql

30 paquetes a quitar.
Luego de la operación, se liberarán 205,2 MiB.
¿Desea continuar? [s/n/? mostrar todas las opciones] (s): n

please, help me to configure postfix without yast mail and with the default files of the SLED installation.
I want configure because i'm use a testing software but i can't use the mail for sent the passwords or bugs issues (testlink and mantis bug traker).

thanks in advance.