Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: How-to use YaST for Updates (help)

  1. #1

    How-to use YaST for Updates (help)

    ok, so, i have ent server 11.1 sp1 as a base OS in VM. it needs updating. server team has not yet done all of the proper support stuff yet so i resgistered for the 60 eval. my Novell portal shows i have eval code and an assigned system. what URL do i use for YaST to grab the updates??

  2. #2

    Re: How-to use YaST for Updates (help)

    If you are using Server you're in the wrong forum but never mind, the process is the same for Desktop and Server

    If you are setting up a new machine I recommend you use the recently released SP2.

    As for your actual question, you say you see the machine in the Novell portal so I'm assuming that means you registered it with Novell Customer Centre. If that's the case your repos should have been set up as part of the registration process. What output do you get from
    Code:
    $ zypper lr -u

  3. #3

    Re: How-to use YaST for Updates (help)

    Quote Originally Posted by asteffek View Post
    ok, so, i have ent server 11.1 sp1 as a base OS in VM. it needs updating. server team has not yet done all of the proper support stuff yet so i resgistered for the 60 eval. my Novell portal shows i have eval code and an assigned system. what URL do i use for YaST to grab the updates??
    If you have configured the SLES server to use the evaluation code (either using YaST's Novell Customer registration module or using the 'suse_register -a email=<ncc account email> -a regcode-sles=<eval code>')

    Once the server is registered, 'zypper sl' should show the online update repositories for SLES.

    Then run YaST > Online Update and accept updates as given or follow the prompts when running 'zypper up'.

    Cheers,
    Willem
    Knowledge Partner (voluntary sysop)
    ---
    If you find a post helpful and are logged into the web interface,
    please show your appreciation and click on the star below it. Thanks!

  4. #4

    Re: How-to use YaST for Updates (help)

    Quote Originally Posted by mikewillis View Post
    If you are using Server you're in the wrong forum but never mind, the process is the same for Desktop and Server

    If you are setting up a new machine I recommend you use the recently released SP2.

    As for your actual question, you say you see the machine in the Novell portal so I'm assuming that means you registered it with Novell Customer Centre. If that's the case your repos should have been set up as part of the registration process. What output do you get from
    Code:
    $ zypper lr -u
    i am not in front of system now.

    ok, let me give some more details. the initial registration failed via YaST because i didnt have my proxy set, so i did the reg manually on Novell site using only "hostname" and "name", no GID hash because there was none on the system. the system is in "systems" section of my support portal but it shows the system has not yet checked in, etc.

    as for repo, there was (was before i ditched it) the repo pointing to cd/dvd. i removed that repo from the list, so YaST now shows no repos. i need to create the repo list from Novell site, but when i run the option to ADD a repo destination i try HTTP and HTTPS but i dont know the URL to use. i tried you.novell.com with path of "update" but it fails. i need correct repo and update site, etc.

    and yes, i need to get this sles fully patched on SP2, etc.

    thnx.
    Last edited by asteffek; 12-Mar-2012 at 22:21.

  5. #5

    Re: How-to use YaST for Updates (help)

    Ah, OK. Ditching the DVD repo was a good move. Have a look in YaST and you should find a module called Novell Customer Centre Configuration. Run that, give it your evaluation code, that should set up all the repos. Accessing the repos requires license (eval or purchased) so you can't just add add an url in YaST.

  6. #6

    Re: How-to use YaST for Updates (help)

    Quote Originally Posted by mikewillis View Post
    Ah, OK. Ditching the DVD repo was a good move. Have a look in YaST and you should find a module called Novell Customer Centre Configuration. Run that, give it your evaluation code, that should set up all the repos. Accessing the repos requires license (eval or purchased) so you can't just add add an url in YaST.
    yes, i tried that, i do get the text screen that asks for my reg email and activation code, but when i enter the activation code as seen in the portal i get a "invalid activation code" after it attempts to connect, this is why its confusing, i am using the code that is in the portal (the code that is the "product" code for the 60day support eval, etc). also, there were some notes somewhere (forget where) that says if you dont have activation code it will register with a 15day period, etc. i tried both and both ways failed. i will try again.
    Last edited by asteffek; 12-Mar-2012 at 23:21.

  7. #7

    Re: How-to use YaST for Updates (help)

    Quote Originally Posted by Magic31 View Post
    If you have configured the SLES server to use the evaluation code (either using YaST's Novell Customer registration module or using the 'suse_register -a email=<ncc account email> -a regcode-sles=<eval code>')

    Once the server is registered, 'zypper sl' should show the online update repositories for SLES.

    Then run YaST > Online Update and accept updates as given or follow the prompts when running 'zypper up'.

    Cheers,
    Willem
    ok, i think i will delete the "system" i manually entered into the portal and try this again from scratch. thnx.

  8. #8

    Re: How-to use YaST for Updates (help)

    Quote Originally Posted by Magic31 View Post
    If you have configured the SLES server to use the evaluation code (either using YaST's Novell Customer registration module or using the 'suse_register -a email=<ncc account email> -a regcode-sles=<eval code>')

    Once the server is registered, 'zypper sl' should show the online update repositories for SLES.

    Then run YaST > Online Update and accept updates as given or follow the prompts when running 'zypper up'.

    Cheers,
    Willem
    suse_register returns an error "invalid code". not sure why, its the code that is shown in my Novell products portal. perhaps the code i have is incorrect type, i have sles 11 sp1 ent server for vmware, but the portal just says sles ent server.

  9. #9

    Re: How-to use YaST for Updates (help)

    edit - yep, wrong product type initially. i got correct type and suse_register registered just fine, but when i run yast to get online updates i get an error "repoindex.xml[1] EntityRef: expecting ';' "

    i just select OK and it continues..... but i need to fix this error, so why does complain about repoindex.xml ?
    Last edited by asteffek; 13-Mar-2012 at 15:07.

  10. #10

    Re: How-to use YaST for Updates (help)

    Quote Originally Posted by asteffek View Post
    edit - yep, wrong product type initially. i got correct type and suse_register registered just fine, but when i run yast to get online updates i get an error "repoindex.xml[1] EntityRef: expecting ';' "

    i just select OK and it continues..... but i need to fix this error, so why does complain about repoindex.xml ?
    Possibly one of the registered repositories is bogus.

    Look and/or post the output of 'zypper lr -u' here (the command Mike Willis mentioned, which will show repositories and their links).

    Cheers,
    Willem
    Knowledge Partner (voluntary sysop)
    ---
    If you find a post helpful and are logged into the web interface,
    please show your appreciation and click on the star below it. Thanks!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •