Results 1 to 5 of 5

Thread: hostip param on boot prompt does not work (on SLES11SP2)

  1. #1

    hostip param on boot prompt does not work (on SLES11SP2)

    Hello,

    i try to install a SLES11SP2 with autoyast in a vmware. I took the generated autoyast.xml file from the end of a normal installation (same vmware parameters) and put this on a webserver in the same ip segment.
    I started the new machine from dvd (iso image) and on the boot prompt I used the following parameters:

    hostip=10.1.1.1 netmask=255.255.255.0 autoyast=http://10.1.1.100/autoyast.xml

    The system was booting and started the yast in "autoyast mode", but got no ip address. I tried to ping from the other server, no response.
    So I canceled the installation an started a bash from the text menu and configured the ip via ifconfig. After this, I run the installation again.

    Now the autoyast.xml was loaded from the webserver and the installation finished.
    Why does the booting SLES ind the vmware not take the ip from the parameter hostip?


    Second problem is, that now the eth1 is available but don't get a configuration from the xml and
    the configured eth0 is not found. How can i change/prevent this?


    Thanks Meike

  2. #2

    Re: hostip param on boot prompt does not work (on SLES11SP2)

    I can just confirm your first problem. hostip does not work for me either (I tried with 2 and 1 NICs too).
    Even leaving it empty (when linuxrc should send out a BOOTP request) does not have any effect. linuxrc bug?

  3. #3

    Re: hostip param on boot prompt does not work (on SLES11SP2)

    OK - using these parameters
    hostip=10.0.0.1/24 gateway=10.0.0.254 nameserver=10.0.0.249 vnc=1 vncpassword=password123
    network gets configured - probably the vnc setting triggers the network config since without vnc=1 eth0 remains unconfigured.
    I suppose your autoyast install would work with specifying vnc=1 vncpassword=dummypass .

  4. #4

    Re: hostip param on boot prompt does not work (on SLES11SP2)

    I found the solutions...

    Quote Originally Posted by meikestone View Post
    Hello,

    i try to install a SLES11SP2 with autoyast in a vmware. I took the generated autoyast.xml file from the end of a normal installation (same vmware parameters) and put this on a webserver in the same ip segment.
    I started the new machine from dvd (iso image) and on the boot prompt I used the following parameters:

    hostip=10.1.1.1 netmask=255.255.255.0 autoyast=http://10.1.1.100/autoyast.xml

    The system was booting and started the yast in "autoyast mode", but got no ip address. I tried to ping from the other server, no response.
    So I canceled the installation an started a bash from the text menu and configured the ip via ifconfig. After this, I run the installation again.

    Now the autoyast.xml was loaded from the webserver and the installation finished.
    Why does the booting SLES ind the vmware not take the ip from the parameter hostip?
    It is necessary to use the additional parameter netsetup, the it works.
    The Line should look like:

    netsetup=1 hostip=10.1.1.1 netmask=255.255.255.0 autoyast=http://10.1.1.100/autoyast.xml


    Quote Originally Posted by meikestone View Post
    Second problem is, that now the eth1 is available but don't get a configuration from the xml and
    the configured eth0 is not found. How can i change/prevent this?
    I removed the complete net-udev part for eth0, and it works:
    Code:
        <net-udev config:type="list">
          <rule>
            <name>eth0</name>
            <rule>ATTR{address}</rule>
            <value>00:50:56:bb:52:3f</value>
          </rule>
        </net-udev>

  5. #5

    Re: hostip param on boot prompt does not work (on SLES11SP2)

    I have got the same problems and spent nearly a day until I read your helpful remarks. This seems to be just a feature of linuxrc - In the text explaining all the options for the linuxrc boot prompt ( http://en.opensuse.org/SDB:Linuxrc ) it reads:

    "netsetup: Prompt for network parameters and setup network. Normally linuxrc will do this automatically when you install via network. But if you want to configure the network even if you install from local media, use this option.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •