Hello,
I am trying to run vnc by starting Xvnc using xinetd. THe remote will connect, but there is a blank screen with a mouse pointer. It appears that the gnome desktop is not starting. I am using SLES12 SP1. chkconfig shows it as 'xinetd'. The problem, I believe is that nothing starts the display manager. I can run vncserver by hand, after I create an xstartup file that starts gnome-session. This will work. xinetd appears to start Xvnc directly which doesn't start the dm. How can I enable VNC without having to manually start the server by using vncserver?

Thank you.