Hi,

Today we were doing an SuSE11 SP2 patching and got the below error:
If you have faced this issue before; please suggest or point us in the right direction.


***** Error *****

Problem retrieving the repository index file for service 'spacewalk':
[|] Traceback (most recent call last):
File "/usr/lib/zypp/plugins/services/spacewalk", line 41, in <module>
from up2date_client.rhncli import utf8_encode
ImportError: cannot import name utf8_encode
Please install package spacewalk-backend-libs.

Skipping service 'spacewalk' because of the above error.

***** end *****


**** excerpt of the things done.. that lead to the error *****

wtsy4dj3:/boot/grub # zypper lr
# | Alias | Name | Enabled | Refresh
---+------------------------------------------------+---------------------------------------+---------+--------
1 | SLES-for-SAP-Applications 11.2.2-1.5 | SLES-for-SAP-Applications 11.2.2-1.5 | Yes | No
2 | spacewalk:sle11-webyast-sp2-pool-x86_64 | SLE11-WebYaST-SP2-Pool for x86_64 | Yes | Yes
3 | spacewalk:sle11-webyast-sp2-updates-x86_64 | SLE11-WebYaST-SP2-Updates for x86_64 | Yes | Yes
4 | spacewalk:sles11-extras-x86_64 | SLES11-Extras for x86_64 | Yes | Yes
5 | spacewalk:sles11-sp1-pool-x86_64 | SLES11-SP1-Pool for x86_64 | Yes | Yes
6 | spacewalk:sles11-sp1-updates-x86_64 | SLES11-SP1-Updates for x86_64 | Yes | Yes
7 | spacewalk:sles11-sp2-core-x86_64 | SLES11-SP2-Core for x86_64 | Yes | Yes
8 | spacewalk:sles11-sp2-extension-store-x86_64 | SLES11-SP2-Extension-Store for x86_64 | Yes | Yes
9 | spacewalk:sles11-sp2-suse-manager-tools-x86_64 | SLES11-SP2-SUSE-Manager-Tools x86_64 | Yes | Yes
10 | spacewalk:sles11-sp2-updates-x86_64 | SLES11-SP2-Updates for x86_64 | Yes | Yes
11 | spacewalk:vmwaredotcom_sles11_sp2_tools_repo | vmwaredotcom_sles11_sp2_tools_repo | Yes | Yes
12 | susemanager-client-setup | susemanager-client-setup | Yes | Yes

wtsy4dj3:/boot/grub # zypper update -t patch
Refreshing service 'spacewalk'.
Failed to mount cd:///?devices=/dev/sr0 on /var/adm/mount/AP_0x00000001: Mounting media failed (mount: no medium found on /dev/sr0)


Please insert medium [] #1 and type 'y' to continue or 'n' to cancel the operation. [yes/no] (no): n
Error building the cache:
[|] Valid metadata not found at specified URL(s)
Warning: Disabling repository 'SLES-for-SAP-Applications 11.2.2-1.5' because of the above error.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW patches are going to be installed:
slesctsp2-softwaremgmt-201302-7358 slessp1-gnome-packagekit-5773 slessp1-slessp1-gnome-packagekit-5773-channel-x86_64 slessp2-libzypp-7165 slessp2-libzypp-8231
slessp2-PackageKit-7256 slessp2-slessp2-libzypp-7165-channel-x86_64 slessp2-slessp2-libzypp-8231-channel-x86_64 slessp2-slessp2-PackageKit-7256-channel-x86_64
slessp2-slessp2-softwaremgmt-201203-5957-channel-x86_64 slessp2-slessp2-softwaremgmt-201205-6408-channel-x86_64
slessp2-slessp2-softwaremgmt-201210-6967-channel-x86_64 slessp2-slessp2-softwaremgmt-201302-7358-channel-x86_64
slessp2-slessp2-softwaremgmt-201306-8047-channel-x86_64 slessp2-slessp2-softwaremgmt-201312-8703-channel-x86_64 slessp2-softwaremgmt-201203-5957
slessp2-softwaremgmt-201205-6408 slessp2-softwaremgmt-201210-6967 slessp2-softwaremgmt-201302-7358 slessp2-softwaremgmt-201306-8047 slessp2-softwaremgmt-201312-8703

The following packages are going to be upgraded:
gnome-packagekit gnome-packagekit-lang libpackagekit-glib10 libzypp PackageKit PackageKit-lang perl-satsolver python-satsolver satsolver-tools yast2-pkg-bindings
yast2-wagon zypper zypper-log zypp-plugin-spacewalk

The following packages are not supported by their vendor:
libzypp satsolver-tools zypper

14 packages to upgrade.
Overall download size: 7.3 MiB. After the operation, 1.1 MiB will be freed.

Continue? [y/n/?] (y): y
Retrieving package python-satsolver-0.44.5-0.5.68.x86_64 (1/14), 251.0 KiB (750.0 KiB unpacked)

Retrieving: python-satsolver-0.44.5-0.5.68.x86_64.rpm [starting]
Retrieving: python-satsolver-0.44.5-0.5.68.x86_64.rpm [done]
Retrieving package perl-satsolver-0.44.5-0.5.68.x86_64 (2/14), 303.0 KiB (944.0 KiB unpacked)

Retrieving: perl-satsolver-0.44.5-0.5.68.x86_64.rpm [starting]
Retrieving: perl-satsolver-0.44.5-0.5.68.x86_64.rpm [done]
Retrieving package zypper-log-1.6.178-0.5.3.x86_64 (3/14), 72.0 KiB (6.0 KiB unpacked)

Retrieving: zypper-log-1.6.178-0.5.3.x86_64.rpm [starting]
Retrieving: zypper-log-1.6.178-0.5.3.x86_64.rpm [done]
Retrieving package satsolver-tools-0.17.7-0.6.2.1.x86_64 (4/14), 350.0 KiB (3.2 MiB unpacked)

Retrieving: satsolver-tools-0.17.7-0.6.2.1.x86_64.rpm [starting]
Retrieving: satsolver-tools-0.17.7-0.6.2.1.x86_64.rpm [3% (13.8 KiB/s)]
Retrieving: satsolver-tools-0.17.7-0.6.2.1.x86_64.rpm [done]
Retrieving package libzypp-9.16.4-0.5.2.x86_64 (5/14), 2.1 MiB (7.1 MiB unpacked)

Retrieving: libzypp-9.16.4-0.5.2.x86_64.rpm [starting]
Retrieving: libzypp-9.16.4-0.5.2.x86_64.rpm [done]
Retrieving package zypper-1.6.178-0.5.3.x86_64 (6/14), 976.0 KiB (4.4 MiB unpacked)

Retrieving: zypper-1.6.178-0.5.3.x86_64.rpm [starting]
Retrieving: zypper-1.6.178-0.5.3.x86_64.rpm [done]
Retrieving package libpackagekit-glib10-0.3.14-2.27.27.17.x86_64 (7/14), 70.0 KiB (193.0 KiB unpacked)

Retrieving: libpackagekit-glib10-0.3.14-2.27.27.17.x86_64.rpm [starting]
Retrieving: libpackagekit-glib10-0.3.14-2.27.27.17.x86_64.rpm [done]
Retrieving package yast2-pkg-bindings-2.17.58-0.5.1.x86_64 (8/14), 531.0 KiB (1.9 MiB unpacked)

Retrieving: yast2-pkg-bindings-2.17.58-0.5.1.x86_64.rpm [starting]
Retrieving: yast2-pkg-bindings-2.17.58-0.5.1.x86_64.rpm [done]
Retrieving package PackageKit-0.3.14-2.27.27.17.x86_64 (9/14), 560.0 KiB (2.1 MiB unpacked)

Retrieving: PackageKit-0.3.14-2.27.27.17.x86_64.rpm [starting]
Retrieving: PackageKit-0.3.14-2.27.27.17.x86_64.rpm [done]
Retrieving package yast2-wagon-2.17.32.4-0.5.1.noarch (10/14), 64.0 KiB (270.0 KiB unpacked)

Retrieving: yast2-wagon-2.17.32.4-0.5.1.noarch.rpm [starting]
Retrieving: yast2-wagon-2.17.32.4-0.5.1.noarch.rpm [0%]
Retrieving: yast2-wagon-2.17.32.4-0.5.1.noarch.rpm [done]
Retrieving package PackageKit-lang-0.3.14-2.27.27.17.x86_64 (11/14), 113.0 KiB (528.0 KiB unpacked)

Retrieving: PackageKit-lang-0.3.14-2.27.27.17.x86_64.rpm [starting]
Retrieving: PackageKit-lang-0.3.14-2.27.27.17.x86_64.rpm [done]
Retrieving package gnome-packagekit-lang-0.3.14-2.86.10.x86_64 (12/14), 1.2 MiB (7.4 MiB unpacked)

Retrieving: gnome-packagekit-lang-0.3.14-2.86.10.x86_64.rpm [starting]
Retrieving: gnome-packagekit-lang-0.3.14-2.86.10.x86_64.rpm [done]
Retrieving package gnome-packagekit-0.3.14-2.86.10.x86_64 (13/14), 758.0 KiB (3.8 MiB unpacked)

Retrieving: gnome-packagekit-0.3.14-2.86.10.x86_64.rpm [starting]
Retrieving: gnome-packagekit-0.3.14-2.86.10.x86_64.rpm [done]
Retrieving package zypp-plugin-spacewalk-0.9.5-0.5.5.x86_64 (14/14), 23.0 KiB (59.0 KiB unpacked)

Retrieving: zypp-plugin-spacewalk-0.9.5-0.5.5.x86_64.rpm [starting]
Retrieving: zypp-plugin-spacewalk-0.9.5-0.5.5.x86_64.rpm [done]

Installing: python-satsolver-0.44.5-0.5.68 [0%]
Installing: python-satsolver-0.44.5-0.5.68 [\]
Installing: python-satsolver-0.44.5-0.5.68 [done]

Installing: perl-satsolver-0.44.5-0.5.68 [0%]
Installing: perl-satsolver-0.44.5-0.5.68 [done]

Installing: zypper-log-1.6.178-0.5.3 [0%]
Installing: zypper-log-1.6.178-0.5.3 [done]

Installing: satsolver-tools-0.17.7-0.6.2.1 [0%]
Installing: satsolver-tools-0.17.7-0.6.2.1 [done]

Installing: libzypp-9.16.4-0.5.2 [0%]
Installing: libzypp-9.16.4-0.5.2 [50%]
Installing: libzypp-9.16.4-0.5.2 [78%]
Installing: libzypp-9.16.4-0.5.2 [95%]
Installing: libzypp-9.16.4-0.5.2 [done]

Installing: zypper-1.6.178-0.5.3 [0%]
Installing: zypper-1.6.178-0.5.3 [50%]
Installing: zypper-1.6.178-0.5.3 [done]
Additional rpm output:
Starting SuSEconfig, the SuSE Configuration Tool...
Running module permissions only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.permissions...
Checking permissions and ownerships - using the permissions files
/etc/permissions
/etc/permissions.easy
/etc/permissions.d/mail-server
/etc/permissions.d/postfix
/etc/permissions.d/sapconf-uuidd
/etc/permissions.local
setting /usr/sbin/zypp-refresh-wrapper to root:root 4755. (wrong permissions 0755)
Finished.



Installing: libpackagekit-glib10-0.3.14-2.27.27.17 [0%]
Installing: libpackagekit-glib10-0.3.14-2.27.27.17 [done]

Installing: yast2-pkg-bindings-2.17.58-0.5.1 [0%]
Installing: yast2-pkg-bindings-2.17.58-0.5.1 [done]

Installing: PackageKit-0.3.14-2.27.27.17 [0%]
Installing: PackageKit-0.3.14-2.27.27.17 [50%]
Installing: PackageKit-0.3.14-2.27.27.17 [done]

Installing: yast2-wagon-2.17.32.4-0.5.1 [0%]
Installing: yast2-wagon-2.17.32.4-0.5.1 [done]

Installing: PackageKit-lang-0.3.14-2.27.27.17 [0%]
Installing: PackageKit-lang-0.3.14-2.27.27.17 [done]

Installing: gnome-packagekit-lang-0.3.14-2.86.10 [0%]
Installing: gnome-packagekit-lang-0.3.14-2.86.10 [67%]
Installing: gnome-packagekit-lang-0.3.14-2.86.10 [done]

Installing: gnome-packagekit-0.3.14-2.86.10 [0%]
Installing: gnome-packagekit-0.3.14-2.86.10 [50%]
Installing: gnome-packagekit-0.3.14-2.86.10 [done]

Installing: zypp-plugin-spacewalk-0.9.5-0.5.5 [0%]
Installing: zypp-plugin-spacewalk-0.9.5-0.5.5 [done]
Warning: One of installed patches affects the package manager itself. Run this command once more to install any other needed patches.


wtsy4dj3:/boot/grub # zypper update -t patch
Refreshing service 'spacewalk'.

Removing repository 'SLE11-WebYaST-SP2-Pool for x86_64' [\]
Removing repository 'SLE11-WebYaST-SP2-Pool for x86_64' [\]
Removing repository 'SLE11-WebYaST-SP2-Pool for x86_64' [|]
Removing repository 'SLE11-WebYaST-SP2-Pool for x86_64' [done]

Removing repository 'SLE11-WebYaST-SP2-Updates for x86_64' [|]
Removing repository 'SLE11-WebYaST-SP2-Updates for x86_64' [/]
Removing repository 'SLE11-WebYaST-SP2-Updates for x86_64' [-]
Removing repository 'SLE11-WebYaST-SP2-Updates for x86_64' [done]

Removing repository 'SLES11-Extras for x86_64' [/]
Removing repository 'SLES11-Extras for x86_64' [\]
Removing repository 'SLES11-Extras for x86_64' [|]
Removing repository 'SLES11-Extras for x86_64' [done]

Removing repository 'SLES11-SP1-Pool for x86_64' [-]
Removing repository 'SLES11-SP1-Pool for x86_64' [/]
Removing repository 'SLES11-SP1-Pool for x86_64' [-]
Removing repository 'SLES11-SP1-Pool for x86_64' [done]

Removing repository 'SLES11-SP1-Updates for x86_64' [\]
Removing repository 'SLES11-SP1-Updates for x86_64' [\]
Removing repository 'SLES11-SP1-Updates for x86_64' [|]
Removing repository 'SLES11-SP1-Updates for x86_64' [done]

Removing repository 'SLES11-SP2-Core for x86_64' [|]
Removing repository 'SLES11-SP2-Core for x86_64' [/]
Removing repository 'SLES11-SP2-Core for x86_64' [-]
Removing repository 'SLES11-SP2-Core for x86_64' [done]

Removing repository 'SLES11-SP2-Extension-Store for x86_64' [/]
Removing repository 'SLES11-SP2-Extension-Store for x86_64' [\]
Removing repository 'SLES11-SP2-Extension-Store for x86_64' [|]
Removing repository 'SLES11-SP2-Extension-Store for x86_64' [done]

Removing repository 'SLES11-SP2-SUSE-Manager-Tools x86_64' [-]
Removing repository 'SLES11-SP2-SUSE-Manager-Tools x86_64' [/]
Removing repository 'SLES11-SP2-SUSE-Manager-Tools x86_64' [-]
Removing repository 'SLES11-SP2-SUSE-Manager-Tools x86_64' [done]

Removing repository 'SLES11-SP2-Updates for x86_64' [\]
Removing repository 'SLES11-SP2-Updates for x86_64' [\]
Removing repository 'SLES11-SP2-Updates for x86_64' [|]
Removing repository 'SLES11-SP2-Updates for x86_64' [done]

Removing repository 'vmwaredotcom_sles11_sp2_tools_repo' [|]
Removing repository 'vmwaredotcom_sles11_sp2_tools_repo' [/]
Removing repository 'vmwaredotcom_sles11_sp2_tools_repo' [-]
Removing repository 'vmwaredotcom_sles11_sp2_tools_repo' [done]
Problem retrieving the repository index file for service 'spacewalk':
[|] Traceback (most recent call last):
File "/usr/lib/zypp/plugins/services/spacewalk", line 41, in <module>
from up2date_client.rhncli import utf8_encode
ImportError: cannot import name utf8_encode
Please install package spacewalk-backend-libs.

Skipping service 'spacewalk' because of the above error.
Failed to mount cd:///?devices=/dev/sr0 on /var/adm/mount/AP_0xTWtkuv: Mounting media failed (mount: no medium found on /dev/sr0)


Please insert medium [] #1 and type 'y' to continue or 'n' to cancel the operation. [yes/no] (no): n
Error building the cache:
[|] Valid metadata not found at specified URL(s)
Warning: Disabling repository 'SLES-for-SAP-Applications 11.2.2-1.5' because of the above error.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Nothing to do.

wtsy4dj3:/boot/grub # zypper lr
# | Alias | Name | Enabled | Refresh
--+--------------------------------------+--------------------------------------+---------+--------
1 | SLES-for-SAP-Applications 11.2.2-1.5 | SLES-for-SAP-Applications 11.2.2-1.5 | Yes | No
2 | susemanager-client-setup | susemanager-client-setup | Yes | Yes

wtsy4dj3:/boot/grub #
wtsy4dj3:/boot/grub #
wtsy4dj3:/boot/grub #
wtsy4dj3:/boot/grub # rhnreg_ks --force --activationkey=1-783e253fbd97c9cef4042db49e96c80e

wtsy4dj3:/boot/grub # zypper ref -s
Refreshing service 'spacewalk'.
Problem retrieving the repository index file for service 'spacewalk':
[|] Traceback (most recent call last):
File "/usr/lib/zypp/plugins/services/spacewalk", line 41, in <module>
from up2date_client.rhncli import utf8_encode
ImportError: cannot import name utf8_encode
Please install package spacewalk-backend-libs.

Skipping service 'spacewalk' because of the above error.
All services have been refreshed.
Repository 'susemanager-client-setup' is up to date.
All repositories have been refreshed.

Thanks