Results 1 to 2 of 2

Thread: Second VNC connection fails and GNOME crash

Threaded View

  1. #1

    Second VNC connection fails and GNOME crash

    Hi Experts,

    I recently upgraded my server from SLES 11 SP3 to SLES 12 SP1. I used to have Xvnc setup before and worked OK for multiple session logins

    After upgrade, I am able to only connect with one instance of VNC per user. Second session fails due to GNOME issues

    Below is what I can see from the syslog

    2016-08-11T10:31:28.066697+00:00 testserver org.a11y.Bus[9901]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
    2016-08-11T10:31:28.067147+00:00 testserver org.a11y.atspi.Registry[9908]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
    2016-08-11T10:31:28.067963+00:00 testserver ca.desrt.dconf[9901]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
    2016-08-11T10:31:28.107840+00:00 testserver polkitd[1691]: Unregistered Authentication Agent for unix-session:c21 (system bus name :1.392, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
    2016-08-11T10:31:28.170262+00:00 testserver display-manager[6630]: Failed to remove slave program access to the display. Trying to proceed.
    2016-08-11T10:31:28.556507+00:00 testserver gnome-session[10001]: WARNING: Failed to acquire org.gnome.SessionManager
    2016-08-11T10:31:28.673721+00:00 testserver display-manager[6630]: GLib-GObject: g_object_ref: assertion 'object->ref_count > 0' failed
    2016-08-11T10:31:28.673885+00:00 testserver display-manager[6630]: GLib-GObject: g_object_unref: assertion 'object->ref_count > 0' failed
    2016-08-11T10:31:28.683318+00:00 testserver xinetd[6598]: EXIT: vnc1 status=0 duration=11(sec)
    2016-08-11T10:31:29.510281+00:00 testserver PackageKit: daemon quit

    ===========

    With my limited knowledge on the SUSE/GNOME, Looks like the gnome is unable to spawn a another instance ?

    I could find lot of threads describing what to be done to fix the issue related to "WARNING: Failed to acquire org.gnome.SessionManager". However none of them work on my server. Here are the rpm list currently installed on my server.

    rpm -qa | grep gnome

    gnome-shell-browser-plugin-3.10.4-54.1.x86_64
    gnome-vfs2-2.24.4-24.45.x86_64
    gnome-terminal-lang-3.10.2-2.9.noarch
    libgnomeui-2.24.5-15.93.x86_64
    gnome-keyring-pam-32bit-3.10.1-21.1.x86_64
    libgnomesu-1.0.0-352.84.x86_64
    gnome-session-3.10.1-7.16.x86_64
    libgnome-2.32.1-14.86.x86_64
    gnome-desktop-lang-3.10.2-7.21.noarch
    gnome-power-manager-3.10.1-2.170.x86_64
    gnome-keyring-lang-3.10.1-21.1.noarch
    libgnome-desktop-3-8-3.10.2-7.21.x86_64
    libgnome-desktop-3_0-common-3.10.2-7.21.x86_64
    gnome-doc-utils-0.20.10-10.11.noarch
    libgnome-keyring-lang-3.10.1-1.64.noarch
    gnome-bluetooth-3.10.0-2.72.x86_64
    gnome-icon-theme-symbolic-3.10.1-1.7.noarch
    gnome-user-docs-3.10.3-1.5.noarch
    gnome-nettool-lang-3.8.1-7.1.noarch
    libgnomecanvas-lang-2.30.3-13.108.noarch
    libgnomesu0-1.0.0-352.84.x86_64
    libgnome-32bit-2.32.1-14.86.x86_64
    libproxy1-config-gnome3-0.4.11-11.6.x86_64
    libgnomecanvas-2-0-2.30.3-13.108.x86_64
    gnome-user-docs-lang-3.10.3-1.5.noarch
    bundle-lang-gnome-en-13.1-2.2.8.noarch
    gnome-session-default-session-3.10.1-7.16.x86_64
    gnome-packagekit-3.10.1-13.50.x86_64
    libgnomekbd-3.6.0-5.114.x86_64
    yast2-control-center-gnome-3.1.10-1.1.x86_64
    gnome-vfs2-32bit-2.24.4-24.45.x86_64
    gnome-mime-data-2.18.0-160.24.noarch
    gnome-doc-utils-lang-0.20.10-10.11.noarch
    gnome-menus-lang-3.10.1-1.235.noarch
    gnome-power-manager-lang-3.10.1-2.170.noarch
    libgnomekbd-lang-3.6.0-5.114.noarch
    libgnomeui-32bit-2.24.5-15.93.x86_64
    gnome-shell-3.10.4-54.1.x86_64
    gnome-pty-helper-0.34.9-1.84.x86_64
    gnome-version-3.10.2-7.21.x86_64
    desktop-data-SLES-extra-gnome-11-24.13.31.noarch
    gnome-terminal-3.10.2-2.9.x86_64
    gnome-menus-branding-SLE-12-1.34.noarch
    gnome-keyring-pam-3.10.1-21.1.x86_64
    gnome-vfs2-lang-2.24.4-24.45.noarch
    gnome-system-monitor-3.10.2-1.202.x86_64
    libgnome-bluetooth12-3.10.0-2.72.x86_64
    libgnome-menu-3-0-3.10.1-1.235.x86_64
    gnome-nettool-3.8.1-7.1.x86_64
    gnome-themes-3.0.0-13.14.noarch
    libgnomeui-lang-2.24.5-15.93.noarch
    gnome-settings-daemon-3.10.2-27.1.x86_64
    gnome-control-center-3.10.3-26.1.x86_64
    gnome-audio-2.22.2-1.17.noarch
    polkit-gnome-lang-0.105-8.86.noarch
    gnome-icon-theme-3.10.0-1.9.noarch
    gnome-keyring-3.10.1-21.1.x86_64
    gnome-menus-3.10.1-1.235.x86_64
    gnome-icon-theme-extras-3.6.2-4.1.2.noarch
    libgnome-keyring0-3.10.1-1.64.x86_64
    gnome-packagekit-lang-3.10.1-13.50.noarch
    gnome-system-monitor-lang-3.10.2-1.202.noarch
    libgnomecanvas-2-0-32bit-2.30.3-13.108.x86_64
    gnome-bluetooth-lang-3.10.0-2.72.noarch
    libgck-modules-gnome-keyring-3.10.1-21.1.x86_64
    gnome-session-core-3.10.1-7.16.x86_64
    libgnomesu-lang-1.0.0-352.84.noarch
    gnome-shell-search-provider-nautilus-3.10.1-15.5.x86_64
    libgnome-lang-2.32.1-14.86.noarch
    gnome-settings-daemon-lang-3.10.2-27.1.noarch
    gnome-themes-accessibility-3.10.0-1.75.noarch
    libgnome-keyring0-32bit-3.10.1-1.64.x86_64
    polkit-gnome-0.105-8.86.x86_64


    rpm -qa | grep vnc
    xorg-x11-Xvnc-1.4.3-14.1.x86_64


    Appreciate your help in fixing this issues

    BR,
    sshark
    Last edited by sshark; 13-Aug-2016 at 14:54.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •