since a few weeks i am having troubles registering new clients to SUSE Manager 2.1. I had no problems for 400+ Servers but now i can`t register any new maschines. I can easily recreate it with any maschine that is already registered to the SUSE Manager.

When i install a new maschine via Autoyast and try to run the Bootstrapscript afterwards i get this error:

* registering
Traceback (most recent call last):
File "/usr/sbin/rhnreg_ks", line 33, in <module>
from up2date_client import rhnreg
File "/usr/share/rhn/up2date_client/rhnreg.py", line 21, in <module>
import hardware
File "/usr/share/rhn/up2date_client/hardware.py", line 52, in <module>
from hardware_hal import check_hal_dbus_status, get_hal_computer, read_hal
ImportError: No module named hardware_hal

I tried to recreate it with an updated maschine that is already registered to SUSE Manager. These are my findings on it:

1. When I delete the System from SUSE Manager and rerun the Bootstrap Script on the target Maschine it is registered without any problem.

2. When I delete the System from SUSE Manager and follow this "Unregister Maschines Guide" https://www.novell.com/support/kb/doc.php?id=7013242 and try to rerun the Bootstrap Script it fails with the same Error above.

3. Newly installed Maschines installed via Autoyast with Repositories that are Updated every week also fail to register with the same Error.

Could somebody point out what i am missing?

Thanks alot in advance