My company uses kiwi to build appliance images: OVA, ISO, PXE, etc. We would like to deploy our OVA appliance to the cloud. I have tried several methods, none of which have worked so far. I apologize if my use of AWS terminology is incorrect, I'm new to this technology.

1. Use SUSE Studio to create EC2 image.

We failed to convert the E2C to an AMI:

C:\Program Files\Amazon\AWSCLI>aws ec2 describe-import-image-tasks --import-task-ids import-ami-ffovb0wm
    "ImportImageTasks": [
            "Status": "active",
            "SnapshotDetails": [
                    "UserBucket": {
                        "S3Bucket": "viservicesbucket",
                        "S3Key": "Amazon_SLES_12_SP1_JeOS.x86_64-0.0.1.raw"
                    "DiskImageSize": 4294967296.0,
                    "Description": "vi_vw5_suse12sp1_jay",
                    "Format": "RAW"
            "Description": "vw5susejay",
            "StatusMessage": "ServerError: an internal error has occurred during conversion.",
            "ImportTaskId": "import-ami-ffovb0wm"
2. Try another method. I deployed one of the SLES images provided by SUSE on AWS. I then uploaded a zypper repo with our application and installed the appropriate packages. After the installation, /bin/ls was almost empty. Somehow one of the most important directories was trashed. Very strange and difficult to troubleshoot. I can't run anything very useful anymore. I'm not sure how 'zypper up' could do this.

3. Try yet another method: We installed the vCenter Connector which allows us to import a VM with our application on it to the AWS cloud. This failed too:
import task failed with status message:
ClientError: Unsupported kernel version 3.0.101-80-default
Ideally, I would like use method 1 and use kiwi to generate a native image. Is there a tutorial for this approach?