Results 1 to 2 of 2

Thread: iptables xt_TEE module on SLES11

Threaded View

  1. iptables xt_TEE module on SLES11


    We have a customer running SLES11 SP2 on a server where we need to do some traffic redirection tricks. Specifically we need to redirect incoming UDP stream to several different hosts on the same LAN, in addition to receiving it on the original host. I was hoping to use iptables TEE extension for this, which worked fine on my own machine with another distribution:

    iptables -t mangle -A PREROUTING -i $interface -p udp -d $myip --dport $port -j TEE --gateway $otherhost1
    iptables -t mangle -A PREROUTING -i $interface -p udp -d $myip --dport $port -j TEE --gateway $otherhost2
    However, when I tried to run the same commands on SLES, I discovered that the necessary xt_TEE kernel module is not available on SLES11 SP2. I quickly installed some virtual machines with SLES11 SP3 and SLES11 SP4 and found that this module is also not present there. I tried SLE12 next, and in that version the module is present and everything works.

    Of course, SLES11 SP2 is quite old, but having to tell the customer "you need to upgrade to SLE12" is somewhat heavy. Is there an easier way to get the necessary xt_TEE module into the existing SLES11 SP2?
    Last edited by vatson; 15-Nov-2016 at 21:09.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts