Quote Originally Posted by rgigler
same issue here. upgraded a SLES11SP1 box to SP2: vmware workstation
7.1.4 gets broken.

building the modules fails with:

CC [M] /tmp/vmware-root/modules/vmmon-only/linux/driver.o

/tmp/vmware-root/modules/vmmon-only/linux/driver.c:788:59: error:
'SPIN_LOCK_UNLOCKED' undeclared here (not in a function)
make[4]: *** [/tmp/vmware-root/modules/vmmon-only/linux/driver.o] Error
1



So I tried version 7.1.6 (which was released after SP2). No luck.

I found patch vmware2.6.39patchv3.tar.bz2 on the Web.

patched vmreqver= in line 7 of the shell script.
holle # diff patch-modules_2.6.39.sh patch-modules_2.6.39.sh_3.0
7c7
< vmreqver=7.1.4
---
> vmreqver=7.1.6


and did run the patch script.It just worked :-)

Whenever i start a VM, I get a nice dialog saying:
"The version of the Linux kernel is newer than the newest series with
which VMware Workstation is supported. It may or may not work. Would you
like to continue ?"

Thanks to VMware for triggering me to buy another update from them
(just because of an OS upgrade ?!?) :-((((

Hi
I just use vmware player these days and kvm... I did manage to patch my
6.x.x version and get the modules to compile, but it wouldn't run.....

Then there is always virtualbox?

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.38-0.5-default
up 17:01, 2 users, load average: 0.29, 0.32, 0.27
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU