Hello, I am trying to install on SLED-12 SP2 three key programs which I cannot find in the SUSE package searches. Its been years since I've been on linux so working to get the key programs I need installed on SLED 12. I had problems installing with Tumbleweed so I have upgraded to SLED-12.

The programs applications are R/Rstudio and OpenCPN. Both could not install on opensuse Tubleweed so I am trying to see if SLED will work. The YAST tool for SLED seems to be far more limited in the applications packages than that for opensuse.

using a 'sudo zypper install qgis' command returns an invalid repository on SLED but did work on Tumbleweed. P

1. OPENCPN - http://opencpn.org/ocpn/download

This is the Tumbleweed error. I have now installed/upgraded to SLED12 hoping to resolve this issue with OPENCPN
@Beta:~> opencpn
Mismatch between program and library build version detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1010, wx containers, compatible with 2.6),
and your program used 2.8 (no debug, Unicode,compiler with C++ ABI 1002,wx containers, compatible with 2.6).
Aborted (core dumped)
@Beta:~>



2. R/Rstudio - https://www.rstudio.com/
and https://www.r-project.org/
This was the error from Tumbleweed that I am hoping the enterprise version (SLED-12) will resolve
Beta:~ # rstudi
rstudio: error while loading shared libraries:
libboost_date_time.so.1.54.0: cannot open shared object file: No such
file or directory
Beta:~ #

### YaST2 conflicts list - generated 2016-11-15 19:44:33 ####

nothing provides libboost_date_time.so.1.54.0()(64bit) needed by
rstudio-0.98.501-1.62.x86_64

[ ] do not install rstudio-0.98.501-1.62.x86_64

[ ] break rstudio-0.98.501-1.62.x86_64 by ignoring some of its dependencies


#### YaST2 conflicts list END ###

3. QGIS - https://software.opensuse.org/package/qgis I do not see where it has a version for SLED12?


Any advice on how to install on SLED-12 even for packages that are not pre-listed on SLED library like R/R-studio and OPENCPN.

Thank you for your assistance.

Ag