I received the notification that SP2 is available. I clicked through the Show Distribution Upgrade and I get this message:

There are some conflicts on the transaction that must be solved manually.

ati-fglrxG02-kmp-dfault-8.801_2.6.32.12_07-110.1x86_64
requires kernel(default:drivers_char_agp_agpgart_ =
753b79eada2ee339, but this requirement cannot be provided

Then I get options:
1. install ati-fglrxG02-kmp-default-8.872_3.0.13_0.9-1.1.x86_64 (with
vendor change_
2. openSUSE Build Service --> SUSE PLDP Build Service:
home: poswald:ati:sle11spx
3. deinstallation of kernel-default-2.6.32.54-0.3.1.x86_64
4. do not install product:SUSE_SLED-11.2-1.513.x86_64
5. break ati-fglrxG02-kmp-default by ignoring some of its dependecies

The next error:
sled-release-11.2-1.513.x86_64 requires sled-release =
11.2-1.513, but this requirement cannot be provided

the options:

uninstallabe providers: sled-release-11.2-1.513.x86_64
[nu_novell_com:SLED11-SP2_Updates]
1. deinstallation of kernel-default-extra-2.6.32.54-0.3.1.x86_64
2. install x11-video-fglrxG02-8.872-2.x86_64 (with vendor change)
openSUSE Build Service --> SUSE LINUX Products GmbH,
Nuernberg, Germany
3. do no install sled-release-11.2-1.513.x86_64
4. do not install sled-release-11.2-1.513.x86_64
5. break SUSE_SLED by ignoring some of its dependencies

Sorry about the long windedness. I can't post attachments so I have to type it out.

I am very much a novice at Linux so any advice would be greatly appreciated as to what options I should choose.

Thanks in advance,

David