Hi all!

We are testing autoyast feature to 'clone' one of our servers with a SLES12 sp1 that has SSH as a service and it si automatically started when booting the system. We created the autoinst.xml from executing yast2 clone_system from the original server and then configured our TFTP server to use this file to install other servers. At this point, we manage to finish the stage 1 of the automated installation by autoyast rebooting the system to continue the configuration with the stage 2.

The main problem we are currently facing is that the system booted does not have the SSH service enabled nor running, so we can't continue the installation/configuration of the system remotely by executing yast.ssh. We would like to know if this can't be changed (nor SSH service possible after stage 1) or if it may be because of an error in our autoinst.xml

This is what we have in autoinst.xml related to services-manager:

<services-manager>
<default_target>multi-user</default_target>
<services>
<disable config:type="list"/>
<enable config:type="list">
<service>10gb</service>
<service>btrfsmaintenance-refresh</service>
<service>cron</service>
<service>dm-event</service>
<service>getty@tty1</service>
<service>glusterfs-client</service>
<service>haveged</service>
<service>irqbalance</service>
<service>iscsi</service>
<service>kdump</service>
<service>postfix</service>
<service>purge-kernels</service>
<service>rollback</service>
<service>rsyslog</service>
<service>smartd</service>
<service>sshd</service>
<service>sssd</service>
<service>systemd-readahead-collect</service>
<service>systemd-readahead-replay</service>
<service>wicked</service>
<service>wickedd-auto4</service>
<service>wickedd-dhcp4</service>
<service>wickedd-dhcp6</service>
<service>wickedd-nanny</service>
<service>YaST2-Firstboot</service>
<service>YaST2-Second-Stage</service>
</enable>
</services>
</services-manager>

Does some of you manage to get the SSH service enabled after the first installation with autoyast? If we connect locally to the installed machine we can check that the open-ssh packages are installed, but checking the service with systemctl status sshd returns it is disabled.