Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Server rebooting on USB Modem unplug

  1. #1

    Server rebooting on USB Modem unplug

    Hi everyone

    I have an issue with USB 3G modem on SLES 11 SP4.

    When I unplug the USB Modem or resetting it from the console the server goes to reboot.

    On SLES 11 SP3 I don't any problem and modem working without any issue.

    I am using usb_modeswitch to get modem works.

    Resetting the modem with the command
    usb_modeswitch -R -v 12d1 -p 1506
    This command works ok on SLES 11 SP3
    But when I run this command on SLES 11 SP4 the server going to reboot.

  2. #2

    Re: Server rebooting on USB Modem unplug

    Hey guys, anyone?

  3. #3

    Re: Server rebooting on USB Modem unplug

    Have you looked for any clues in the /var/log/messages?
    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below this post. Thanks.

  4. #4

    Re: Server rebooting on USB Modem unplug

    Hi KBOYLE,

    yes I've looked for errors in /var/log/messages, /var/log/warn without any result.

    There are no errors in the log files.

    I wanna mention I have two clean installed OSes on VMware - SLES 11 SP3 and SLES 11 SP4.

    I faced this problem on SLES 11 SP4 but SLES 11 SP3 working good.

    Also the USB modem detection differs on OSes

    SLES 11 SP4:
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
    Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
    Bus 001 Device 003: ID 12d1:1506 Huawei Technologies Co., Ltd. Modem/Networkcard

    SLES 11 SP3:
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 004: ID 12d1:1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard
    Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
    Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub

    I'm using the same USB modem - HUAWEI E303

  5. #5

    Re: Server rebooting on USB Modem unplug

    Hi William,

    Can you open a Service Request? That may be the best way to get this issue resolved.

    Please remember that these forums are staffed by volunteers and that support is provided on a "best effort' basis. Some issues are too complex or require too much debugging to resolve via the forums.

    I'm sorry, but I don't have any ideas on this one. If anyone else has any suggestions to offer, I'm sure they will provide whatever help they can but, due to the holidays, it may take a few days.

    If you do resolve this issue, could you please update this thread so we can all benefit from your experience?

    Thank you.
    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below this post. Thanks.

  6. #6

    Re: Server rebooting on USB Modem unplug

    Hi Kevin,

    I will update this thread on any additional information.

    I wanna add additional information:
    After facing this proble I've updated SLES 11 SP4 till august 20, 2016 to check if there any changes but without any luck. Even updateed SLES 11 SP4 going to reboot after unplugging USB modem or resseting it from the console.

    How can I open a Service Request?

    Thank you

  7. #7

    Re: Server rebooting on USB Modem unplug

    Quote Originally Posted by plokijuh View Post
    How can I open a Service Request?
    These are the SUSE Linux Enterprise Server Product Support options available to you.

    The SUSE Customer Center is where you can open a Service Request but you require an active maintenance subscription to do so.
    Kevin Boyle - Knowledge Partner
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below this post. Thanks.

  8. #8

    Re: Server rebooting on USB Modem unplug

    Hi Kevin,

    unfortunately I do not have active Maintenance Subscription to open s Service Request.

    Try to resolve that issue myself or as a workaround just reinstall the OS on that server to SLES 11 SP3.

    I will keep update this post as soon as new information is coming.

    Thank you.

  9. #9

    Re: Server rebooting on USB Modem unplug

    plokijuh Wrote in message:

    > unfortunately I do not have active Maintenance Subscription to open s
    > Service Request.
    >
    > Try to resolve that issue myself or as a workaround just reinstall the
    > OS on that server to SLES 11 SP3.
    >
    > I will keep update this post as soon as new information is coming.


    Are you are to try with a SLES11 SP3 server then upgrade to SLES11
    SP4? I'm curious whether the problem exists with SLES11 SP4
    (install or upgrade) or just fresh installs of SLES11 SP4 - the
    answer might help identify the cause of this problem.


    HTH.
    --
    Simon Flood
    SUSE Knowledge Partner


    ----Android NewsGroup Reader----
    http://usenet.sinaapp.com/

  10. #10

    Re: Server rebooting on USB Modem unplug

    Hi Simon,

    I've tried on SLES 11 SP3 and had no issue with the USB modem.

    Then I decided to use SLES 11 SP4 (not updated, I've used ISO file) because of some critical security updates which weren't present in SLES 11 SP3 I got this problem.

    After that I updated SLES 11 SP4 with available updates till august 20, 2016 without any changes. Even with the updates SLES 11 SP4 rebooting on unplug or resseting USB modem.

    Thak you

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •