Quote Originally Posted by smflood View Post
shinroo Wrote in message:

> Hello, I am working on a Lenovo ThinkPad T560 running SLES 12 SP1.
> Everything is great, except for the fact that I cannot connect to any
> wifi networks since it seems I don't have any wlan interface.
> Running lspci, I can see that the card is indeed present.
>> D068902@wdfl34067123a:~/Downloads/iwlwifi-8000-ucode-> lspci
>> 00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM
>> Registers (rev 08)
>> 00:02.0 VGA compatible controller: Intel Corporation Skylake Integrated
>> Graphics (rev 07)
>> 00:08.0 System peripheral: Intel Corporation Skylake Gaussian Mixture
>> Model
>> 00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI
>> Controller (rev 21)
>> 00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP
>> Thermal subsystem (rev 21)
>> 00:16.0 Communication controller: Intel Corporation Sunrise Point-LP
>> CSME HECI #1 (rev 21)
>> 00:16.3 Serial controller: Intel Corporation Device 9d3d (rev 21)
>> 00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA
>> Controller [AHCI mode] (rev 21)
>> 00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
>> 00:1c.2 PCI bridge: Intel Corporation Device 9d12 (rev f1)
>> 00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller
>> (rev 21)
>> 00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev
>> 21)
>> 00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev
>> 21)
>> 00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
>> 00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection
>> I219-LM (rev 21)
>> 02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A
>> PCI Express Card Reader (rev 01)
>> 04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)

> But, if I run iwconfig there are no wlan interfaces listed
>> D068902@wdfl34067123a:~/Downloads/iwlwifi-8000-ucode->
>> iwconfig
>> eth0 no wireless extensions.
>> lo no wireless extensions.

> I have downloaded the firmware for the card iwlwifi-8000C-13.ucode and
> put it in the folder /lib/firmware
> The card does not show up in Yast (I tried setting it up from there, but
> to no avail).
> I've been bashing my head against this problem for a while now. I have a
> project to work on, and need the laptop since it has all the
> certificates and proxies installed for work, ideally I'd take it to IT
> but they said it might take a while and I don't have that much time. So
> I need to sort this out myself for now. That being said, a temporary
> solution would be fine too since I could then take it to IT to have a
> look at once the project is done.
> Any help would be greatly appreciated.
> Thanks in advance!

Is there a particular reason you're using SLES12 SP1 and not the
latest SLES12 SP2? The release is important because SP1 includes
Linux kernel 3.12 whilst SP2 has 4.4 and I think it's the latter
you need, or at least kernel 4.2, to support the Intel 8260
wireless chip. And to preempt a possible question, no you can't
upgrade the kernel in SP1 to 4.2 or later.

Simon Flood
SUSE Knowledge Partner

First of all, thanks so much for the reply. To answer your question: the reason I'm using SLES SP1 is because that was provided to me and company policy is not such that I can simply reinstall the OS. I guess I will need to take it to IT and let them handle it. At least I will be able to tell them where the problem lies! Thanks so much.