Greetings, I was performing an update that ended with a message stating some packages will not be installed. I ran an update against one of the packages and received the following results. I need an explanation of the message and directions on how to proceed.
Code:
linux140:/mnt/suse/s390x # zypper update PackageKit-backend-zypp
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: PackageKit-backend-zypp-0.8.16-15.1.s390x requires libzypp.so.1519()(64bit), but this requirement cannot be provided
  uninstallable providers: libzypp-15.21.1-7.1.s390x[SLES12SP1-Update]
                   libzypp-15.21.4-10.2.s390x[SLES12SP1-Update]
                   libzypp-15.22.0-19.1.s390x[SLES12SP1-Update]
                   libzypp-15.22.2-25.1.s390x[SLES12SP1-Update]
                   libzypp-15.23.1-30.1.s390x[SLES12SP1-Update]
                   libzypp-15.19.5-1.14.s390x[mnt]
 Solution 1: Following actions will be done:
  deinstallation of libyui-ncurses-pkg6-2.46.1-3.4.s390x
  deinstallation of libyui-qt-pkg6-2.44.7-3.2.s390x
 Solution 2: do not install PackageKit-backend-zypp-0.8.16-15.1.s390x
 Solution 3: break PackageKit-backend-zypp-0.8.16-15.1.s390x by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c):