Thanks a lot for the fast reply! I installed radvd on a fresh SLES 12 SP2 instance and received the following data during radvddump:

# radvd configuration generated by radvdump 1.9.7
# based on Router Advertisement from fe80::47a:8fff:fe31:d557
# received by interface eth0

interface eth0
	AdvSendAdvert on;
	# Note: {Min,Max}RtrAdvInterval cannot be obtained with radvdump
	AdvManagedFlag on;
	AdvOtherConfigFlag off;
	AdvReachableTime 0;
	AdvRetransTimer 0;
	AdvCurHopLimit 64;
	AdvDefaultLifetime 1800;
	AdvHomeAgentFlag off;
	AdvDefaultPreference medium;
	AdvSourceLLAddress on;

	prefix 2a05:d014:70b:xxxx::/64
		AdvValidLifetime infinity; # (0xffffffff)
		AdvPreferredLifetime infinity; # (0xffffffff)
		AdvOnLink off;
		AdvAutonomous off;
		AdvRouterAddr off;
	}; # End of prefix definition

}; # End of interface definition
So, there is an RA, "managed" is "on" and "other-config" is "off", right?
If I understand you correctly, this advertisement should be fine.

Explicitly setting DHCLIENT6_MODE=managed in the ifcfg file did not help.

BTW, I also tried SLES 11 SP4 as EC2 instance and IPv6 worked fine after enabling general IPv6 support and installing the RPM "dhcpv6".