So far I've had a miserable time with SLED.

Bought new bits for a PC that I wanted to start actually *using* this weekend (it's now Sunday night, and the machine is still useless) for some FPGA development, put them together and bought a copy of SLED, because that's what Xilinx (the company that makes my FPGA) supports along with RedHat.

The initial install goes ok, apart from two things:

1) The mouse doesn't work with the KVM switch I have. If the mouse is plugged into the machine, everything is fine. Plug it into the KVM and the mouse behavior is ... erratic to say the least. I've found several "fixes" for this on the net, none of which work. So far I've tried:

- Changing the protocol to 'auto' away from the ps/2 variant. No difference even after a reboot

- Configuring X to use the evdev driver (as in Novell knowledge base article 7006748). No difference, even after another reboot.

My mouse is still plugged into the machine itself... Not an auspicious start.

2) The network on the motherboard (an ASUS P8Z68-V) doesn't work, because SLED tries to use the RTL8169 device driver and its an RTL8111 chip. The 8169 driver is widely known to be broken for a large swathe of 8111 chips, so it's particularly disappointing that the buggy device driver is still being shipped. To solve this, I found the following on linuxquestions:
  1. Downloaded r8168-8.004.00 driver from http://wiki.centos.org/HardwareList/RealTekRTL8111b
  2. $ tar jxvf r8168-8.005.00.tar.bz2 # i unpacked this on the desktop
  3. $ sudo mv r8168-8.004.00 /usr/src # move the driver directory from desktop to /usr/src
  4. $ cd /usr/src/r8168-8.004.00
  5. $ sudo make clean modules
  6. $ sudo make install
  7. $ sudo depmod -a
  8. $ sudo insmod ./src/r8168.ko
  9. $ lsmod -a | grep 8186 #just to check it was there
  10. $ cd /etc/modprobe.d
  11. $ sudo touch blacklist-network
  12. $ vi blacklist-network # add r1869 to black list


So now I'm almost there. Now I try to update to SP2 (since the download link was to the SP0 when I bought the support) using 'wagon' as root - I found that on these forums, it wasn't obvious from the Desktop how to change the service-pack level... I was rather hoping that the above two things would have been fixed in the service packs... so:

3) run wagon as root. Let it do its stuff, and an hour and a reboot later, I have ... a mess.

- Now, the 'main menu' applet crashes and won't reload. There's no easy way to get to anything now. Fortunately I'd dragged a GnomeTerminal icon onto the desktop, because otherwise I'd be SOL. Also, it seems to have only gone to SP1, well, ok perhaps it has to do it in stages...

4) Also, the network no longer works (well, ok, if it hasn't been fixed I sort of expected that might happen), so I go to do my above routine, and ... it fails. Looks as though the kernel source might have been removed ? Not sure because I had to change the baby's diaper so I was in a rush, but step #5 now fails with 'make' aborting with a 'file not found' message (from memory). So hey, I'm SOL anyway. No network, no way to get a network. Great.

5) So then I decide, what the hell, I'll download and do a fresh install of SP2 this evening - I've got the early shift with the baby so there's plenty of time to download the DVD, burn it, and start the reinstall, right ? Nope. After registering on Novell's site, it seems there's no link to my credentials on Suse's site (which knows about my "digital rights" to support) so even though the box itself could potentially (if it had a network) download the service pack, I can't do it from my Mac. There doesn't appear to be anywhere I can just type in my "digital rights" code, either.

Frankly, this level of run-around is what I expect from a fly-by-night seat-of-the-pants one-guy-who-does-it-all startup, not a company which claims its support is its distinguishing feature. QA is clearly lacking, and QA is essentially what we're all paying for. So now it seems the only way forward with Suse would be to get a network card that it doesn't screw the driver up for, and use 2 mice on the desktop, one for the Suse machine, one for the other 3 machines.

As I said at the start, colour me unimpressed.

Simon