SUSE Linux Enterprise Server 12 SP2 (x86_64) - Lab VM trial for SUMA.

Issue #1 - info
Sadly there doesn't seem to be any provision for a proxy during the initial installation of SLES12. The network config stuff is nice, but desperately needs a proxy string addition step yesternow. All the great work you've done on the subsequent menus (like selecting SUMA as an add on) is probably meaningless to anyone working behind a proxy until you do.

Issue #2 - show stopper
In either yast or with SUSEConnect attempts to register the server instance fail with the error:
Code:
getaddrinfo: Name or service not known
DNS Resolution and Proxy access have been configured and wget used to confirm access is ok:
Code:
wget https://scc.suse.com
--2017-03-06 14:42:00--  https://scc.suse.com/
...
017-03-06 14:42:03 (26.2 KB/s) - ‘index.html’ saved [12468/12468]
Here's highlights from SUSEConnect
Code:
# SUSEConnect -e my@email.address -r <rego code> -u https://scc.suse.com --debug
Executing: 'zypper targetos' Quiet: false
Output: 'sle-12-x86_64'
opening connection to :...
SUSEConnect error: SocketError: getaddrinfo: Name or service not known
Using https://updates.suse.com (or http:// variants of the two) had the same result.

Can anyone tell me how to get more diagnostic output from this command, ideally around the "miracle occurs not" bit after opening connection part which is a touch vague! A clue as to the underlying command would help me run it to find out what its reacting to.

Here is the full diag output from SUSEConnect (replaced email/reg with x's):
Code:
# SUSEConnect -e my@email.address -r <rego code>  -u https://scc.suse.com --debug
cmd options: '{:email=>"XXXXX", :token=>"xxxxxxxxxxxxxx", :url=>"https://scc.suse.com", :write_config=>true, :debug=>true, :language=>"en_AU.UTF-8"}'
Merged options: #<SUSE::Connect::Config insecure=false, url="https://scc.suse.com", email="xxxxxxxx", token="xxxxxxxxxxxxx", write_config=true, debug=true, language="en_AU.UTF-8">
Executing: 'uname -i' Quiet: false
Output: 'x86_64'
Executing: 'lscpu' Quiet: false
Output: 'Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             AuthenticAMD
CPU family:            21
Model:                 48
Model name:            AMD A8-7650K Radeon R7, 10 Compute Cores 4C+6G
Stepping:              1
CPU MHz:               3294.018
BogoMIPS:              6588.03
Hypervisor vendor:     KVM
Virtualization type:   full
L1d cache:             16K
L1i cache:             64K
L2 cache:              2048K
NUMA node0 CPU(s):     0,1
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm rep_good nopl extd_apicid pni pclmulqdq ssse3 cx16 sse4_1 sse4_2 x2apic popcnt aes xsave avx hypervisor lahf_lm cmp_legacy cr8_legacy abm sse4a misalignsse 3dnowprefetch arat vmmcall'
Executing: 'uname -i' Quiet: false
Output: 'x86_64'
Executing: 'dmidecode -s system-uuid' Quiet: false
Output: 'XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX'
Executing: 'zypper targetos' Quiet: false
Output: 'sle-12-x86_64'
opening connection to :...
SUSEConnect error: SocketError: getaddrinfo: Name or service not known
/usr/lib64/ruby/2.1.0/net/http.rb:879:in `initialize'
/usr/lib64/ruby/2.1.0/net/http.rb:879:in `open'
/usr/lib64/ruby/2.1.0/net/http.rb:879:in `block in connect'
/usr/lib64/ruby/2.1.0/timeout.rb:76:in `timeout'
/usr/lib64/ruby/2.1.0/net/http.rb:878:in `connect'
/usr/lib64/ruby/2.1.0/net/http.rb:863:in `do_start'
/usr/lib64/ruby/2.1.0/net/http.rb:852:in `start'
/usr/lib64/ruby/2.1.0/net/http.rb:1369:in `request'
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.41/lib/suse/connect/connection.rb:60:in `json_request'
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.41/lib/suse/connect/connection.rb:42:in `block (2 levels) in <class:Connection>'
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.41/lib/suse/connect/api.rb:63:in `announce_system'
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.41/lib/suse/connect/client.rb:48:in `announce_system'
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.41/lib/suse/connect/client.rb:151:in `announce_or_update'
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.41/lib/suse/connect/client.rb:26:in `register!'
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.41/lib/suse/connect/cli.rb:47:in `execute!'
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.41/bin/SUSEConnect:11:in `<top (required)>'
/usr/sbin/SUSEConnect:23:in `load'
/usr/sbin/SUSEConnect:23:in `<main>'