Hi,

I'm trying to setup Suse private cloud 7 environment on virtual platform by following the deployment guide https://www.suse.com/documentation/suse-openstack-cloud-7/book_cloud_deploy/data/book_cloud_deploy.html provided by Suse.
> After executing the *"crowbarctl database create"* it's error with the following message.
> crowbarctl database create --debug
> RestClient.head "http://127.0.0.1/api/database/new", "Accept"=>"*/*",
> "Accept-Encoding"=>"gzip, deflate", "User-Agent"=>"rest-client/2.0.0
> (linux-gnu x86_64) ruby/2.1.2p95"
> # => 404 NotFound | text/html 0 bytes
> RestClient.post "http://127.0.0.1/api/database/new",
> "username&password", "Accept"=>"application/vnd.crowbar.v2.0+json",
> "Accept-Encoding"=>"gzip, deflate", "Content-Length"=>"17",
> "Content-Type"=>"application/x-www-form-urlencoded",
> "User-Agent"=>"rest-client/2.0.0 (linux-gnu x86_64) ruby/2.1.2p95"
> /usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/request.rb:790:in
> `rescue in transmit': Timed out reading data from server
> (RestClient::Exceptions::ReadTimeout)
> from
> /usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/request.rb:704:in
> `transmit'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/request.rb:221:in
> `execute'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/request.rb:52:in
> `execute'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/rest-client-2.0.0/lib/restclient/resource.rb:67:in
> `post'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/lib/crowbar/client/request/base.rb:69:in
> `process'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/lib/crowbar/client/command/database/create.rb:43:in
> `execute'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/lib/crowbar/client/app/database.rb:63:in
> `create'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/command.rb:27:in
> `run'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/invocation.rb:126:in
> `invoke_command'
> from /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor.rb:359:in
> `dispatch'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/invocation.rb:115:in
> `invoke'
> from /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor.rb:235:in
> `block in subcommand'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/command.rb:27:in
> `run'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/invocation.rb:126:in
> `invoke_command'
> from /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor.rb:359:in
> `dispatch'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/thor-0.19.1/lib/thor/base.rb:440:in
> `start'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/lib/crowbar/client/util/runner.rb:50:in
> `execute!'
> from
> /usr/lib64/ruby/gems/2.1.0/gems/crowbar-client-3.2.1/bin/crowbarctl:34:in
> `<top (required)>'
from /usr/bin/crowbarctl:23:in `load'
from /usr/bin/crowbarctl:23:in `<main>'

Any help to fix this issue would be appreciated.

Thank you,
NC