Results 1 to 2 of 2

Thread: Demo license for SLES 11 SP2 and HA extension - problems

Hybrid View

  1. #1

    Demo license for SLES 11 SP2 and HA extension - problems

    Hi,

    I have two boxes running SLES 11 and the HA extension added, I have the clusters "up" and syncing configs, but when I try to mount a ocfs2 partition manually I keep getting "mount.ocfs2: Unable to access cluster service while trying initialize cluster". crm_mon shows two failed action which are the mount of the ocfs file system as well. I see this in the log:
    Apr 11 10:11:11 fs2 Filesystem(ocfs2-1:0)[6347]: [6394]: INFO: Running start for /dev/sdb2 on /srv/clusterfs
    Apr 11 10:11:12 fs2 lrmd: [6201]: info: RA output: (ocfs2-1:0:start:stderr) mount.ocfs2
    Apr 11 10:11:12 fs2 lrmd: [6201]: info: RA output: (ocfs2-1:0:start:stderr) :
    Apr 11 10:11:12 fs2 lrmd: [6201]: info: RA output: (ocfs2-1:0:start:stderr) Cluster stack specified does not match the one currently running
    Apr 11 10:11:12 fs2 lrmd: [6201]: info: RA output: (ocfs2-1:0:start:stderr)
    Apr 11 10:11:12 fs2 lrmd: [6201]: info: RA output: (ocfs2-1:0:start:stderr) while trying to join the group
    Apr 11 10:11:12 fs2 lrmd: [6201]: info: RA output: (ocfs2-1:0:start:stderr)
    Apr 11 10:11:12 fs2 Filesystem(ocfs2-1:0)[6347]: [6415]: ERROR: Couldn't mount filesystem /dev/sdb2 on /srv/clusterfs
    Apr 11 10:11:12 fs2 lrmd: [6201]: info: operation start[10] on ocfs2-1:0 for client 6204: pid 6347 exited with return code 1


    Ive done a lot of digging and it seems that in ocfs 1.5.0 o2cb is now combined direct into ocfs? All the solutions I see are o2cb is not running, which maybe is the case but I can't start it because I see zero binaries for that and no init scripts or anything referencing o2cb, im stumped to say the least.

    Does anyone have any ideals I can try? I need to get drbd on top of this but right now i can't even get ocfs to mount so I can't get any farther.

    Thanks

  2. Re: Demo license for SLES 11 SP2 and HA extension - problems

    Hi touchtone1,

    while I have no SP2 system up & running here yet, I guess that OCFS2 is still usable with different cluster stacks underneath.

    How's your OCFS2 configured?
    Code:
    # cat /sys/fs/ocfs2/cluster_stack 
    pcmk
    #
    Regards,
    Jens

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •