Hi,

todays SUSE-SLE-SERVER-12-SP2-2017-624 may break SUSEConnect if your
environment uses the 'no_proxy' variable.

The cause seems to be that a pre-final PTF made it into the update.
There is one part missing to the solution of bsc#1014863, namely
https://github.com/ruby/ruby/commit/...a4a08dcfdc1275

You can easily apply it by hand to /usr/lib64/ruby/2.1.0/uri/generic.rb
if you already applied the patch or wait for a fixed version of the patch.

Franz