Results 1 to 6 of 6

Thread: Problems with autofs

Hybrid View

  1. #1
    Join Date
    Nov 2014
    Location
    Pleasant Valley, New York 12569
    Posts
    167

    Problems with autofs

    The /net/home files are not mounting. The /net/home directory is empty.
    I have the domain set but I do receive this message: " lookup_init:136: lookup(yp): map auto.master: Local domain name not set".
    I do not know why this message is issued: "key "updates" not found in map source(s).".

    Code:
    linux158:~ # systemctl status autofs
    autofs.service - Automounts filesystems on demand
       Loaded: loaded (/usr/lib/systemd/system/autofs.service; enabled)
       Active: active (running) since Mon 2017-05-01 11:58:24 EDT; 1h 24min ago
         Docs: man:automount(8)
               man:autofs(5)
      Process: 1881 ExecStart=/usr/sbin/automount $AUTOFS_OPTIONS -p /var/run/automount.pid (code=exited, status=0/SUCCESS)
     Main PID: 1894 (automount)
       CGroup: /system.slice/autofs.service
               └─1894 /usr/sbin/automount -p /var/run/automount.pid
    
    May 01 12:00:44 linux158 automount[1894]: key "updates" not found in map source(s).
    Code:
    linux158:~ # cat /var/log/messages | grep automount
    2017-04-24T14:05:57.917171-04:00 linux158 automount[1460]: lookup_init:136: lookup(yp): map auto.master: Local domain name not set
    2017-04-24T14:14:07.963118-04:00 linux158 automount[1774]: lookup_init:136: lookup(yp): map auto.master: Local domain name not set
    2017-04-24T14:19:55.897599-04:00 linux158 automount[1774]: key "updates" not found in map source(s).
    2017-04-24T14:26:16.058606-04:00 linux158 automount[1883]: lookup_init:136: lookup(yp): map auto.master: Local domain name not set
    2017-04-24T14:59:23.974642-04:00 linux158 automount[1886]: lookup_init:136: lookup(yp): map auto.master: Local domain name not set
    2017-04-24T15:03:07.626498-04:00 linux158 automount[1886]: key "updates" not found in map source(s).
    2017-04-24T15:09:03.749836-04:00 linux158 automount[2163]: lookup_init:136: lookup(yp): map auto.master: Local domain name not set
    2017-04-24T15:09:53.291202-04:00 linux158 automount[1888]: lookup_init:136: lookup(yp): map auto.master: Local domain name not set
    2017-04-29T20:05:53.803638-04:00 linux158 automount[1892]: lookup_init:136: lookup(yp): map auto.master: Local domain name not set
    2017-05-01T10:17:50.728437-04:00 linux158 automount[9980]: lookup_init:136: lookup(yp): map auto.master: Local domain name not set
    2017-05-01T11:52:07.756033-04:00 linux158 automount[1898]: key "depot" not found in map source(s).
    2017-05-01T11:52:30.003292-04:00 linux158 automount[1898]: key "updates" not found in map source(s).
    2017-05-01T12:00:44.145384-04:00 linux158 automount[1894]: key "updates" not found in map source(s).
    Code:
    linux158:/etc # cat hostname
    linux158.rtp.raleigh.ibm.com linux158
    linux158:/etc # cat defaultdomain
    linux158.rtp.raleigh.ibm.com linux158
    linux158:/etc # hostname
    linux158
    Code:
    linux158:~ # cat /etc/auto.master
    # Sample auto.master file
    #/misc  /etc/auto.misc
    # /net  -hosts
    # Include /etc/auto.master.d/*.autofs
    # The included files must conform to the format of this file.
    #+dir:/etc/auto.master.d
    # Include central master map if it can be found using
    # nsswitch sources.
    #+auto.master
    /usr/IBMi    /etc/auto.IBMi
    /net/home    /etc/auto.net.home
    
    linux158:~ # cat /etc/auto.IBMi
    tools -rw,hard,intr,rsize=8192,wsize=8192,nfsvers=3 toolbert.svl.ibm.com:/swat/depot/tools
    depo  -rw,hard,intr,rsize=8192,wsize=8192,nfsvers=3 toolbert.svl.ibm.com:/swat/depot/depo
    linux158:~ # cat /etc/auto.net.home
    #automount users' /net/home dir from paix588 - 20/Nov/2013
    *      paix588.rtp.raleigh.ibm.com:/home/&
    Code:
    linux158:~ # cat /etc/fstab
    /dev/system/swap                        swap                 swap       defaults              0 0
    /dev/system/root                        /                    xfs        defaults              1 1
    /dev/disk/by-path/ccw-0.0.15c1-part1    /boot/zipl           ext2       acl,user_xattr        1 2
    akira.svl.ibm.com:/arsapar              /arsapar             nfs        vers=3,auto           0 0
    akira.svl.ibm.com:/home                 /net/home            nfs        vers=3,auto           0 0
    /dev/pool1/lvopt                        /opt                 ext3       defaults              0 0
    /dev/pool1/lvtmp                        /tmp                 ext3       defaults              0 0
    rdr400r.rtp.raleigh.ibm.com:/arstest2   /arstest2            nfs        vers=3,auto           0 0
    # Mount /arstest2 from the UTR instead
    # paix588.rtp.raleigh.ibm.com:/arstest2   /arstest2            nfs        vers=3,auto         0 0
    # access denied by server while mounting od9aix.svl.ibm.com:/arstest
    # od9aix.svl.ibm.com:/arstest             /arstest             nfs        vers=3,auto           0 0

  2. #2

    Re: Problems with autofs

    mikenash,

    It appears that in the past few days you have not received a response to your
    posting. That concerns us, and has triggered this automated reply.

    These forums are peer-to-peer, best effort, volunteer run and that if your issue
    is urgent or not getting a response, you might try one of the following options:

    - Visit http://www.suse.com/support and search the knowledgebase and/or check all
    the other support options available.
    - Open a service request: https://www.suse.com/support
    - You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://forums.suse.com)

    Be sure to read the forum FAQ about what to expect in the way of responses:
    http://forums.suse.com/faq.php

    If this is a reply to a duplicate posting or otherwise posted in error, please
    ignore and accept our apologies and rest assured we will issue a stern reprimand
    to our posting bot..

    Good luck!

    Your SUSE Forums Team
    http://forums.suse.com



  3. Re: Problems with autofs

    This message:
    May 01 12:00:44 linux158 automount[1894]: key "updates" not found in map source(s).

    means that someone tried to access a subdirectory called "updates" under one of your defined autofs locations, but there is no definition for what to do with the key named "updates". Your autofs locations are /usr/IBMi (mapped in auto.IBMi) and /net/home (mapped in auto.net.home). auto.net.home has a wildcard key, so anything would match that key. So this error cannot be a result of the /net/home configuration or usage. It must be a result of the /usr/IBMi configuration or usage.

    So, put in simplest terms, someone attempted to access /usr/IBMi/updates, but there is no "updates" defined in auto.IBMi (there is only "tools" and "depo"). Therefore, the result (rightfully) is a message that the key, "updates", is not found. This is very common and normal. Any user on your system can try to access anything they can imagine. They might mistype something (depot instead of depo, which has been defined in your config) or they might look for something else (anything) that has not been defined. Any time someone tries to access a subdir under /usr/IBMi that isn't listed in auto.IBMi, a message will occur that the key is not found.

    This cannot happen with your auto.net.home (since a wildcard will match anything and everything). Therefore, this error is not at all pertinent to any problems you are having under /net/home.

    Your other message:
    lookup_init:136: lookup(yp): map auto.master: Local domain name not set

    is quite puzzling to me. This message indicates 2 things: (1) autofs is trying to make yp (nis) queries to find additional auto.master maps. (2) it cannot seem to find the local yp domain name.

    You have pointed out that the yp domain name is present in /etc/defaultdomain. So #2 might be puzzling. But #1 is also puzzling, because your auto.master does not contain anything which would instruct autofs to query yp. The "+auto.master" line is remarked out, so in my view, queries to yp should not happen, unless there was more to your auto.master file than you included here.

    So... why it is querying yp and why it thinks the domain name is not set are both mysterious. But even so, I don't see why either of those would interfere with auto.net.home map usage, because that map is a local file and doesn't require you to get it from the yp database. So it's possible that this message has nothing to do with your problem, either.

    If you don't really need this machine to be a yp client, you might disable ypbind at least temporarily and see if this message goes away, and whether autofs works any better.

    I will do a little more experimenting and post again if I have further suggestions.
    Last edited by dpartrid; 08-May-2017 at 21:34.

  4. Re: Problems with autofs

    Additional reply:

    I added a "+auto.master" to my auto.master file in order to tell autofs to try to talk to yp. Originally, I did this without my machine having been configured to talk to yp (yp client (ypbind) never configured), and nothing in /etc/defaultdomain. And in this state, I did get your same error "map auto.master: Local domain name not set". Then I made my machine a yp client (through yast) and the error stopped.

    Later I disabled yp client and renamed the /etc/defaultdomain file, and rebooted, but even after all that, I have *not* gotten that error to come back. So... I'm a little confused.

    But even when I was getting that error, I did not find it to be interfering with my local autofs maps. So despite the confusion, I am not included to think that this error is pertinent to your /net/home problem.

    But, incidentally, I will add that your defaultdomain file does not appear to be correct format. All it should contain is the name of your yp (nis) domain. instead, yours looks like a host file entry for this machine:

    linux158:/etc # cat defaultdomain
    linux158.rtp.raleigh.ibm.com linux158

    And in fact, it looks like an exact copy of your /etc/hostname file, which it should NOT be. For that matter, I'm not sure your /etc/hostname file is the correct format either. I don't think it's supposed to have both long name and short name in it. That is how you'd make an entry in /etc/hosts (well, you'd put in the ip addr first, also), but this style of naming is not necessarily right for /etc/hostname. Reading online, I'm seeing statements that /etc/hostname should only include the simple host name, without domain name, of the machine. But I'm getting off-topic here.

    Given that your "defaultdomain" file looks more like a host and dns domain information instead of yp domain information, , I wonder whether you even are using the yp client (ypbind) at all. Do you find ypbind running with "ps aus | grep ypbind"? Do you have a /etc/yp.conf file?

    But again, as far as I can tell, this domain name error is not pertinent to your described problem of /net/home being empty / from working.

    You might try editing /etc/sysconfig/autofs, and setting:
    AUTOFS_OPTIONS="-d"
    and then restarting autofs. this will put it into debug mode and it will generate A LOT more messages to look through. Then you can attempt to access /net/home/something and maybe get a better idea of why it fails.
    Last edited by dpartrid; 08-May-2017 at 22:28.

  5. #5
    Join Date
    Nov 2014
    Location
    Pleasant Valley, New York 12569
    Posts
    167

    Re: Problems with autofs

    Greetings dpartrid, thank you for your reply.
    I performed the following process:
    Turned on debugging for autofs.
    Edit /etc/host
    added IP-Address Full-Qualified-Hostname Short-Hostname
    9.42.87.11 linux158.rtp.raleigh.ibm.com linux158
    Turned off debugging for autofs.
    All is well.

  6. #6

    Re: Problems with autofs

    I had the same issue with /etc/auto.master.d

    I just set the domainname and it solved the problem : domainname my.local.domain
    domainname wasn't set for the server and it caused this problem.

    Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •