I tried to update from SLES 11 SP1 to SLES 12 SP2. The first two steps

- SLES 11 SP1 to SLES SP2
- SLES 11 SP2 to SLES SP3

worked without any problems. But the third step

- SLES 11 SP3 to SLES 12 SP2

Gave me an error for several packages:

Installation of package xyz failed

Subprocess failed, Error: RPM failed: /bin/sh:
/usr/local/lib/readline.so.6: no version information available (required by /bin/sh)

/bin/sh: relocation error: /bin/sh: symbol rl_filename_stat_hook, version READLINE_6.3 not defined in file libreadline.so.6 with link time reference

...


zypper tells me readline 5.2 is installed, but obviously /bin/sh references /usr/local/lib/libreadline.so which is linked to libreadline.6.2. Can anybody explain what exactly the problem is and how to get out of this situation?