Results 1 to 3 of 3

Thread: SLES 12 SP2 SAP AMI fails with cloud registration

Hybrid View

  1. #1

    SLES 12 SP2 SAP AMI fails with cloud registration

    I saw there was another thread about issues with cloud registration. Is this an resurfaced issue?

    The system has internet connectivity and can reach the SMT but receives a forbidden.

    This was tested with AMI (ami-8b559e9d) in us-east-1.

    Code:
    Last login: Thu May 18 16:59:23 2017 from 10.184.37.30
    SUSE Linux Enterprise Server 12 SP2 for SAP Applications x86_64 (64-bit)
    
    As "root" (sudo or sudo -i) use the:
      - zypper command for package management
      - yast command for configuration management
    
    Management and Config: https://www.suse.com/suse-in-the-cloud-basics
    Documentation: http://www.suse.com/documentation/sles12/
    Forum: https://forums.suse.com/forumdisplay.php?93-SUSE-Public-Cloud
    
    Have a lot of fun... or not :)
    ec2-user@sles-test-02:~> cat /var/log/cloudregister
    2017-05-18 16:57:50,005 INFO:Using API: regionInfo
    2017-05-18 16:57:50,005 INFO:Using region server: 52.79.82.165
    2017-05-18 16:57:50,009 INFO:Starting new HTTPS connection (1): 52.79.82.165
    2017-05-18 16:57:50,779 INFO:Starting new HTTP connection (1): 54.83.5.54
    2017-05-18 16:57:50,924 INFO:Modified /etc/hosts, added: 54.83.5.54     smt-ec2.susecloud.net   smt-ec2
    
    2017-05-18 16:57:52,502 INFO:[Service] No SMT server found, nothing to do
    2017-05-18 16:57:52,537 INFO:Writing SMT rootCA: /usr/share/pki/trust/anchors
    2017-05-18 16:57:52,540 INFO:Starting new HTTP connection (1): 54.83.5.54
    2017-05-18 16:57:52,544 INFO:Updating CA certificates: update-ca-certificates
    ec2-user@sles-test-02:~>
    ec2-user@sles-test-02:~> zypper lr
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    # | Alias                   | Name                    | Enabled | GPG Check | Refresh
    --+-------------------------+-------------------------+---------+-----------+--------
    1 | nVidia-Driver-SLE12-SP2 | nVidia-Driver-SLE12-SP2 | No      | ----      | ----
    ec2-user@sles-test-02:~> wget https://smt-ec2.susecloud.net
    --2017-05-18 17:02:47--  https://smt-ec2.susecloud.net/
    Resolving smt-ec2.susecloud.net (smt-ec2.susecloud.net)... 54.83.5.54
    Connecting to smt-ec2.susecloud.net (smt-ec2.susecloud.net)|54.83.5.54|:443... connected.
    HTTP request sent, awaiting response... 403 Forbidden
    2017-05-18 17:02:47 ERROR 403: Forbidden.
    
    ec2-user@sles-test-02:~> sudo /usr/sbin/registercloudguest --force-new
    /usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:264: SubjectAltNameWarning: Certificate for 52.79.82.165 has no `subjectAltName`, falling back to check for a `commonName` for now. This feature is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)
      SubjectAltNameWarning
    Traceback (most recent call last):
      File "/usr/sbin/registercloudguest", line 367, in <module>
        if len(failed_smts) == len(known_smt_servers):
    NameError: name 'known_smt_servers' is not defined

  2. #2

    Re: SLES 12 SP2 SAP AMI fails with cloud registration

    christianse,

    It appears that in the past few days you have not received a response to your
    posting. That concerns us, and has triggered this automated reply.

    These forums are peer-to-peer, best effort, volunteer run and that if your issue
    is urgent or not getting a response, you might try one of the following options:

    - Visit http://www.suse.com/support and search the knowledgebase and/or check all
    the other support options available.
    - Open a service request: https://www.suse.com/support
    - You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://forums.suse.com)

    Be sure to read the forum FAQ about what to expect in the way of responses:
    http://forums.suse.com/faq.php

    If this is a reply to a duplicate posting or otherwise posted in error, please
    ignore and accept our apologies and rest assured we will issue a stern reprimand
    to our posting bot..

    Good luck!

    Your SUSE Forums Team
    http://forums.suse.com



  3. Re: SLES 12 SP2 SAP AMI fails with cloud registration

    Quote Originally Posted by christianse View Post
    I saw there was another thread about issues with cloud registration. Is this an resurfaced issue?

    The system has internet connectivity and can reach the SMT but receives a forbidden.

    This was tested with AMI (ami-8b559e9d) in us-east-1.
    Hi,

    First sorry for the delay in response, the issue has been fixed for about a week but the response slipped through the cracks.

    The root cause of the issue was that the API providing us with verification whether or not an instance based on a SUSE image published in Marketplace was trying to register or not did not properly handle the product code assigned to SLES 12 SP2 For SAP images. This has been addressed and everything is working.

    Again please excuse the late response.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •