Dear all,

Host OS: Windows 10
Guest OS Suse 10 SP4
Virtualization: Virtualbox 5.1.12r112440

I've already installed Suse 10 SP 4 in virtualbox. When I try to install readline-devel, it gives me the following error:

Code:
suse10sp4-10205-12102:~ # zypper install readline-devel
Restoring system sources...
Parsing metadata for SUSE Linux Enterprise Server 10 SP4...
Parsing RPM database...
Summary:
<install>   [S1:1][package]readline-devel-5.1-24.26.20.x86_64
Continue? [y/n]: y
Downloading: [S1:1][package]readline-devel-5.1-24.26.20.x86_64, 145.5 K(567.6 K unpacked)
Installing: [S1:1][package]readline-devel-5.1-24.26.20.x86_64
[S1:1][package]readline-devel-5.1-24.26.20.x86_64 Subprocess failed. Error: RPM failed:

Invalid object
Invalid object
Installing: [S1:1][package]readline-devel-5.1-24.26.20.x86_64
[S1:1][package]readline-devel-5.1-24.26.20.x86_64 Subprocess failed. Error: RPM failed:

(with nodeps)Invalid object
(with nodeps)Invalid object
Installing: [S1:1][package]readline-devel-5.1-24.26.20.x86_64
[S1:1][package]readline-devel-5.1-24.26.20.x86_64 Subprocess failed. Error: RPM failed:

(with nodeps+force)Invalid object
(A)bort, (R)etry, (I)gnore?
readline is already installed
Code:
suse10sp4-10205-12102:~ # rpm -qa readline
readline-5.1-24.26.20
Whats should I do to install readline-devel?

While I understand that most likely Suse10 is already out of support, but since my customer is still in Suse 10, I've to simulate according to their specifications.

thanks a lot!