I have recently took over management of our companies VM Servers.

Everything was years out of date, so started with patching up to the latest 5.5 on the hosts and the Server Appliance.

I then upgraded tools on each of the VM's

And then patched all the VM's up to date.

It's been a steep learning curve.

Now i am literally stuck.

I have a Server Appliance running on SUSE 11.2, ideally this would be on a Windows VM from a management point of view but it's not so i'm trying to work with it.

I have upgraded the patches as mentioned but VM Tools is making me hate life.

From what i can make out it is running an OS specific RPM package (this is all new to me) I tried to run the tar.gz package but i get an error saying i need to uninstall the rpm package first in order to install again an easier to manage tar.gz package.

The article on VMware website doesn't work because it is saying could be called or similar to following this guide Uninstalling Open VMware Tools included with Linux distributions (1013096) | VMware KB

I do the rpm - qa | grep vm and the list i get back is longer than my arm, now i know i have version by running vm-toolbox-cmd -v which may help narrow it down.

But i can not run the command rpm -e open-vm-tools-gui open-vm-tools vmware-guest-kmp-desktop From the article without knowing my specific file names.

So i thought ok, stick with the RPM and upgrade that, well that just looked even more complicated but i found this script Installing VMware Tools the easy way - OSP - SUSE Blog | SUSE Communities

Sounds perfect but it's not been updated since 2014 and it's failing even after updating the file paths.

I have seen articles saying to run rm -r /etc/VM-Tools or similar, didn't feel comfortable doing that so renamed the folder, still no joy. Guessing there are other components or needed a reboot but didn't feel taking that any further.

I also saw people saying to run zypper rm -y vmware-tools* which i assume searches and deletes everything vmware-tools related. Again i stopped at the point getting a little out of my comfort zone.

Ideal solution for myself would be to replace the server with a Windows VM but i'm not sure of the process and what that involves. I can follow a guide to setup new but to replace an existing is a different matter.

But short term i would like to update the rpm but preffered option is to remove the rpm and go with the tar.gz because when i do bite the bullet to upgrade from 5.5 or newer tools comes out i will have the same again.

Please help...

p.s. any references to commands may not be entirely accurate as i don't have them in front of me. just to give an idea of what i was running.