Section 4.2 of the installation instructions (Introduction to SUSE Linux Enterprise Server for the Raspberry Pi) strongly recommends the use of 'gcc-6', which is GCC V6.2.1, rather than the default gcc/cc which is V4.8.5.

I assume that this cannot be done for everything - otherwise the old compiler would have just been replaced. Can anyone tell me what requires the older 4.8.5 compiler such that it has to be made the default?

Which compiler was used to build the kernel (assuming kernel modules need to be built with the same one)?

Thanks,
DigbyT