How do I remove wicked in sles12sp2 and install NetworkManager? Preferably through autoyast during the build.


It seems that autoyast still creates /etc/sysconfig/network/ files and wicked does not properly translate the files autoyast creates.

Here is my autoyast interface stanza
<interface>
<bootproto>none</bootproto>
<mtu>9000</mtu>
<ipaddr>19.59.24.209</ipaddr>
<netmask>255.255.254.0</netmask>
<device>eth0</device>
<startmode>auto</startmode>
</interface>


This gets translated to:

cat /etc/sysconfig/network/ifcfg-eth0
BOOTPROTO='none'
IPADDR='19.59.24.209/23'
MTU='9000'
PREFIXLEN='23'
STARTMODE='auto'

Looks fine. I've been using this under sles10 and sles12 for years building thousands of systems without issue.

This fails under wicked:
2017-07-27T12:19:13.333135-04:00 hostname wicked: eth0: hiring nanny
2017-07-27T12:19:13.345819-04:00 hostname wicked: eth0: converting config into policy 'policy__eth0'
2017-07-27T12:19:13.359084-04:00 hostname wicked: eth0: adding policy policy__eth0 to nanny
2017-07-27T12:19:13.373565-04:00 hostname wicked: Calling /org/opensuse/Network/Nanny.createPolicy(policy__eth0)
2017-07-27T12:19:13.373783-04:00 hostname wickedd-nanny[1379]: __ni_dbus_object_message(path=/org/opensuse/Network/Nanny, interface=org.opensuse.Network.Nanny, method=createPoli
cy) called
2017-07-27T12:19:13.374080-04:00 hostname wickedd-nanny[1379]: ni_dbus_connection_get_caller_uid(:1.26): user_id=0
2017-07-27T12:19:13.374235-04:00 hostname wickedd-nanny[1379]: Policy "policy__eth0" already exists
2017-07-27T12:19:13.374390-04:00 hostname wickedd-nanny[1379]: eth1: state=device-up want=network-up, wait-for=link-up
2017-07-27T12:19:13.374544-04:00 hostname wickedd-nanny[1379]: waiting for 1 devices to become ready (1 explicitly requested)
2017-07-27T12:19:13.387564-04:00 hostname wicked: Call to /org/opensuse/Network/Nanny.createPolicy(policy__eth0) failed: Policy already exists
2017-07-27T12:19:13.401624-04:00 hostname wicked: Calling /org/opensuse/Network/Nanny/Policy/policy__eth0.update()
2017-07-27T12:19:13.401841-04:00 hostname wickedd-nanny[1379]: __ni_dbus_object_message(path=/org/opensuse/Network/Nanny/Policy/policy__eth0, interface=org.opensuse.Network.Mana
gedPolicy, method=update) called


and ends up creating this file:
cat /run/wicked/nanny/policy__eth0.xml
<policy name="policy__eth0" origin="compat:suse:/etc/sysconfig/network/ifcfg-eth0" uuid="81127a59-ab46-0500-2d79-000001000000">
<match>
<device>eth0</device>
</match>
<merge>
<name>eth0</name>
<control>
<mode>boot</mode>
</control>
<link>
<mtu>9000</mtu>
</link>
<ipv4>
<enabled>false</enabled>
</ipv4>
<ipv6>
<enabled>false</enabled>
</ipv6>
</merge>
</policy>

Is there a way to get autoyast to work with wicked or just to blacklist wicked from being installed and use NetworkManager?