Hello, All.

I'm having issues registering a SAP HLI to an SMT server. I'm having the issue below. If I need to provide more details, please advise.

Details:
SMT Server:
- SUSE 12 SP1 for SAP in Azure Cloud
- I've mirrored all SLES 12 repositories

HLI Sever:
- SUSE 12 SP1 for SAP in Azure Cloud

Registration Debug
---------------------------------------------------------------
/usr/bin/SUSEConnect --debug --write-config --url https://dummyhost.dummyfqdn/
cmd options: '{:debug=>true, :write_config=>true, :url=>"https://dummyhost.dummyfqdn/", :language=>"POSIX"}'
Merged options: #<SUSE::Connect::Config insecure=false, url="https://dummyhost.dummyfqdn/", debug=true, write_config=true, language="POSIX">
Reading credentials from /etc/zypp/credentials.d/SCCcredentials
Read credentials: SCC_ca0ffb6945284013a64380ca25600371 : c0745e5ee6fd4122a1920c758c396143
Reading credentials from /etc/zypp/credentials.d/SCCcredentials
Read credentials: SCC_ca0ffb6945284013a64380ca25600371 : c0745e5ee6fd4122a1920c758c396143
Executing: 'uname -i' Quiet: false
Output: 'x86_64'
Executing: 'lscpu' Quiet: false
Output: 'Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 192
On-line CPU(s) list: 0-191
Thread(s) per core: 2
Core(s) per socket: 24
Socket(s): 4
NUMA node(s): 4
Vendor ID: GenuineIntel
CPU family: 6
Model: 79
Model name: Intel(R) Xeon(R) CPU E7-8890 v4 @ 2.20GHz
Stepping: 1
CPU MHz: 1200.117
CPU max MHz: 3400.0000
CPU min MHz: 1200.0000
BogoMIPS: 4391.45
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 256K
L3 cache: 61440K
NUMA node0 CPU(s): 0-23,96-119
NUMA node1 CPU(s): 24-47,120-143
NUMA node2 CPU(s): 48-71,144-167
NUMA node3 CPU(s): 72-95,168-191'
Executing: 'uname -i' Quiet: false
Output: 'x86_64'
Executing: 'dmidecode -s system-uuid' Quiet: false
Output: '# SMBIOS implementations newer than version 2.8 are not
# fully supported by this version of dmidecode.
2211AD19-1819-E711-0000-00000000000E'
Executing: 'zypper targetos' Quiet: false
Output: 'sle-12-x86_64'
opening connection to dummyhost.dummyfqdn:443...
opened
starting SSL for dummyhost.dummyfqdn:443...
SSL established
<- "PUT /connect/systems HTTP/1.1\r\nAccept-Encoding: identity\r\nAccept: application/json,application/vnd.scc.suse.com.v4+json\r\nUser-Agent: SUSEConnect/0.2.27\r\nAuthorization: Basic U0NDX2NhMGZmYjY5NDUyODQwMTNhNjQzODBjYTI1NjAwMzcxOm MwNzQ1ZTVlZTZmZDQxMjJhMTkyMGM3NThjMzk2MTQz\r\nCont ent-Type: application/json\r\nAccept-Language: POSIX\r\nConnection: close\r\nHost: dummyhost.dummyfqdn\r\nContent-Length: 301\r\n\r\n"
<- "{\"hostname\":\"sappl1db01\",\"hwinfo\":{\"hostna me\":\"sappl1db01\",\"cpus\":192,\"sockets\":4,\"h ypervisor\":null,\"arch\":\"x86_64\",\"uuid\":\"# SMBIOS implementations newer than version 2.8 are not\\n# fully supported by this version of dmidecode.\\n2211AD19-1819-E711-0000-00000000000E\"},\"distro_target\":\"sle-12-x86_64\"}"
-> "HTTP/1.1 200 OK\r\n"
-> "Date: Thu, 17 Aug 2017 09:39:45 GMT\r\n"
-> "Server: Apache\r\n"
-> "scc-api-version: v4\r\n"
-> "Cache-Control: no-cache, public, must-revalidate\r\n"
-> "Pragma: no-cache\r\n"
-> "Connection: close\r\n"
-> "Transfer-Encoding: chunked\r\n"
-> "Content-Type: application/json\r\n"
-> "\r\n"
-> "2\r\n"
reading 2 bytes...
-> "{}"
read 2 bytes
reading 2 bytes...
-> ""
-> "\r\n"
read 2 bytes
-> "0\r\n"
-> "\r\n"
Conn close
Executing: 'zypper --no-refresh --xmlout --non-interactive products -i' Quiet: false
Output: '<?xml version='1.0'?>
<stream>
<message type="info">Loading repository data...</message>
<message type="info">Reading installed packages...</message>
<product-list>
<product name="SLES_SAP" version="12.1" release="0" epoch="0" arch="x86_64" vendor="SUSE" summary="SUSE Linux Enterprise Server for SAP Applications 12 SP1" repo="@System" productline="sles" registerrelease="" shortname="SLE-12-SP1-SAP" flavor="DVD" isbase="true" installed="true"><endoflife time_t="1572480000" text="2019-10-31T01:00:00+01"/><registerflavor/><description>SUSE LINUX Enterprise Server 12 SP1 for SAP Applications</description></product>
</product-list>
</stream>'
Reading credentials from /etc/zypp/credentials.d/SCCcredentials
Read credentials: SCC_ca0ffb6945284013a64380ca25600371 : c0745e5ee6fd4122a1920c758c396143
opening connection to dummyhost.dummyfqdn:443...
opened
starting SSL for dummyhost.dummyfqdn:443...
SSL established
<- "POST /connect/systems/products HTTP/1.1\r\nAccept-Encoding: identity\r\nAccept: application/json,application/vnd.scc.suse.com.v4+json\r\nUser-Agent: SUSEConnect/0.2.27\r\nAuthorization: Basic U0NDX2NhMGZmYjY5NDUyODQwMTNhNjQzODBjYTI1NjAwMzcxOm MwNzQ1ZTVlZTZmZDQxMjJhMTkyMGM3NThjMzk2MTQz\r\nCont ent-Type: application/json\r\nAccept-Language: POSIX\r\nConnection: close\r\nHost: dummyhost.dummyfqdn\r\nContent-Length: 104\r\n\r\n"
<- "{\"identifier\":\"SLES_SAP\",\"version\":\"12.1\" ,\"arch\":\"x86_64\",\"release_type\":null,\"token \":null,\"email\":null}"
-> "HTTP/1.1 422 Unprocessable Entity\r\n"
-> "Date: Thu, 17 Aug 2017 09:39:45 GMT\r\n"
-> "Server: Apache\r\n"
-> "scc-api-version: v4\r\n"
-> "Connection: close\r\n"
-> "Transfer-Encoding: chunked\r\n"
-> "Content-Type: application/json\r\n"
-> "\r\n"
-> "93\r\n"
reading 147 bytes...
-> "{\"error\":\"Product not (fully) mirrored on this server\",\"status\":422,\"localized_error\":\"Prod uct not (fully) mirrored on this server\",\"type\":\"error\"}"
read 147 bytes
reading 2 bytes...
-> ""
-> "\r\n"
read 2 bytes
-> "0\r\n"
-> "\r\n"
Conn close
Error: SCC returned 'Product not (fully) mirrored on this server' (422)
-----------------------------------------------------------------------------------
End of Debug