Hi,

I just installed a 2-nodes cluster with SLES-11.1-for-VMware and HA-extension CDs.
My configuration is plain vanilla. I just specified 'bindnetaddr' and 'mcastaddr' in the conffile and started Corosync (openais).

Corosync seems to work :
Code:
corosync [MAIN  ] Corosync Cluster Engine ('1.2.1'): started and ready to provide service.
corosync [MAIN  ] Corosync built-in features: nss
corosync [MAIN  ] Successfully configured openais services to load
corosync [MAIN  ] Successfully read main configuration file '/etc/corosync/corosync.conf'.
corosync [TOTEM ] Initializing transport (UDP/IP).
corosync [TOTEM ] Initializing transmit/receive security: libtomcrypt SOBER128/SHA1HMAC (mode 0).
corosync [TOTEM ] The network interface [172.29.29.107] is now up.
corosync [SERV  ] Service engine loaded: openais cluster membership service B.01.01
corosync [SERV  ] Service engine loaded: openais event service B.01.01
corosync [SERV  ] Service engine loaded: openais checkpoint service B.01.01
corosync [SERV  ] Service engine loaded: openais availability management framework B.01.01
corosync [SERV  ] Service engine loaded: openais message service B.03.01
corosync [SERV  ] Service engine loaded: openais distributed locking service B.03.01
corosync [SERV  ] Service engine loaded: openais timer service A.01.01
corosync [SERV  ] Service engine loaded: corosync extended virtual synchrony service
corosync [SERV  ] Service engine loaded: corosync configuration service
corosync [SERV  ] Service engine loaded: corosync cluster closed process group service v1.01
corosync [SERV  ] Service engine loaded: corosync cluster config database access v1.01
corosync [SERV  ] Service engine loaded: corosync profile loading service
corosync [SERV  ] Service engine loaded: corosync cluster quorum service v0.1
corosync [MAIN  ] Compatibility mode set to whitetank.  Using V1 and V2 of the synchronization engine.
corosync [CLM   ] CLM CONFIGURATION CHANGE
corosync [CLM   ] New Configuration:
corosync [CLM   ] Members Left:
corosync [CLM   ] Members Joined:
corosync [CLM   ] CLM CONFIGURATION CHANGE
corosync [CLM   ] New Configuration:
corosync [CLM   ] 	r(0) ip(172.29.29.107) 
corosync [CLM   ] Members Left:
corosync [CLM   ] Members Joined:
corosync [CLM   ] 	r(0) ip(172.29.29.107) 
corosync [TOTEM ] A processor joined or left the membership and a new membership was formed.
corosync [CLM   ] CLM CONFIGURATION CHANGE
corosync [CLM   ] New Configuration:
corosync [CLM   ] 	r(0) ip(172.29.29.107) 
corosync [CLM   ] Members Left:
corosync [CLM   ] Members Joined:
corosync [CLM   ] CLM CONFIGURATION CHANGE
corosync [CLM   ] New Configuration:
corosync [CLM   ] 	r(0) ip(172.29.29.106) 
corosync [CLM   ] 	r(0) ip(172.29.29.107) 
corosync [CLM   ] Members Left:
corosync [CLM   ] Members Joined:
corosync [CLM   ] 	r(0) ip(172.29.29.106) 
corosync [TOTEM ] A processor joined or left the membership and a new membership was formed.
corosync [MAIN  ] Completed service synchronization, ready to provide service.
But I can't access its configuration:

Code:
# crm configure
Signon to CIB failed: connection failed
Init failed, could not perform requested operations
ERROR: cannot parse xml: no element found: line 1, column 0
crm(live)configure# show
ERROR: No CIB!
crm(live)configure#
I've never had this problem with other distributions and Google points me to a SLES-specific problem (http://www.gossamer-threads.com/list...ha/users/69796).
I can't find a way to force-create a CIB on Corosync...
Is there any additionnal step needed to get Pacemaker/Corosync to work on SLES ?