Hi Jerome,

as no-one else tried to answer, here come some shots into the dark:

- have you tried running Firefox with a fresh profile, or probably by starting it into "Profile Management" mode ("firefox --ProfileManager")? The latter will tell if it's a profile-related problem, as Firefox will first prompt you *which* profile to use. If that window appears, the problem is probably related to the currently used profile and you should start with a fresh one.

- did you verify that you have write access to the current home directory and that there's still free space available in /tmp, /var and the home directory? Sometimes, obscure errors like the one you're seeing result from out-of-disk-space conditions confusing the software.

- if nothing else help, try running "rpm -V all" as root, to verify the files of all packages. Maybe some code file got corrupted somehow, and the "RPM verify" will tell you. Please note that you will also see a number of "false positives", as config files will be reported, too. I strongly recommend to consult rpm's man page regarding the flags that command will report with its findings.

Regards,
J