# \[1.0.1\] Error when adding host on Azure

**URL:** https://forums.suse.com/t/1-0-1-error-when-adding-host-on-azure/2477
**Category:** Rancher 1.x
**Created:** [April 15, 2016, 7:43pm UTC](https://forums.suse.com/t/1-0-1-error-when-adding-host-on-azure/2477 "2016-04-15T19:43:27Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![chrissom](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/chrissom/32/1220_2.png) [@chrissom](https://forums.suse.com/u/chrissom)
#### Post date: [April 15, 2016, 7:43pm UTC](https://forums.suse.com/t/1-0-1-error-when-adding-host-on-azure/2477/1 "2016-04-15T19:43:27Z")

</div>

Hello,

I installed Rancher 1.0.1 and tried to add a host against Azure.

I got this error: “Error with pre-create check… local error: internal error”.

I’m not getting any error message help here. Here’s logs:

```auto
time="2016-04-15T19:31:15Z" level=info msg="Creating Machine" eventId=c17045b5-7365-46fc-814c-1333f2a11047 resourceId=1ph19
time="2016-04-15T19:31:15Z" level=info msg="Cmd slice: [create -d azure --engine-install-url https://releases.rancher.com/install-docker/1.10.sh --azure-location East US --azure-password ************--azure-size Standard_DS2 --azure-subscription-cert /var/lib/cattle/machine/6ec5f3c0-e234-4cfe-976f-796fc150c268/subscription-cert.pem --azure-subscription-id******** - ****-**** - ****-************ --azure-username myemail@outlook.com lab03]"
time="2016-04-15T19:31:15Z" level=info msg="stdout: Creating CA: /var/lib/cattle/machine/6ec5f3c0-e234-4cfe-976f-796fc150c268/certs/ca.pem" resourceId: =1ph19
time="2016-04-15T19:31:15Z" level=info msg="stdout: Creating client certificate: /var/lib/cattle/machine/6ec5f3c0-e234-4cfe-976f-796fc150c268/certs/cert.pem" resourceId: =1ph19
time="2016-04-15T19:31:16Z" level=info msg="stdout: Running pre-create checks..." resourceId: =1ph19
time="2016-04-15T19:31:23Z" level=info msg="stdout: The default lines below are for a sh/bash shell, you can specify the shell you're using, with the --shell flag." resourceId: =1ph19
time="2016-04-15T19:31:23Z" level=info msg="stdout: " resourceId: =1ph19
time="2016-04-15T19:31:24Z" level=info msg="stderr: Error with pre-create check: \"Get management.core.windows.net/ ********-**** - ****-**** - ************ /services/hostedservices/operations/isavailable/lab03: local error: internal error\"" resourceId=1ph19
time="2016-04-15T19:31:24Z" level=info msg="starting cleanup..." machine name=lab03
time="2016-04-15T19:31:24Z" level=error msg="Error processing event" err="Error with pre-create check: \"Get https://management.core.windows.net/ ********-**** - ****-**** - ************ /services/hostedservices/operations/isavailable/lab03: local error: internal error\"" eventId=c17045b5-7365-46fc-814c-1333f2a11047 eventName="physicalhost.create;handler=goMachineService" resourceId=1ph19

```

---

<div class="post-metadata">

### Author: ![denise](https://avatars.discourse-cdn.com/v4/letter/d/82dd89/32.png) [@denise](https://forums.suse.com/u/denise)
#### Post date: [April 17, 2016, 2:11pm UTC](https://forums.suse.com/t/1-0-1-error-when-adding-host-on-azure/2477/2 "2016-04-17T14:11:48Z")

</div>

Have you tried taking the same docker-machine command to see if you are able to launch the host without using Rancher? The UI is just providing a user friendly way of running docker-machine to launch hosts.

Try creating an instance in Azure using docker-machine with the same command that is in your issue.

```auto
`docker-machine create -d azure --engine-install-url https://releases.rancher.com/install-docker/1.10.sh --azure-location East US --azure-password ************--azure-size Standard_DS2 --azure-subscription-cert /var/lib/cattle/machine/6ec5f3c0-e234-4cfe-976f-796fc150c268/subscription-cert.pem --azure-subscription-id******** - ****-**** - ****-************ --azure-username myemail@outlook.com lab03

```

If it fails with the same error, then smething is incorrect in docker-machine command.
