# Adding windows host - Rancher 2.1

**URL:** https://forums.suse.com/t/adding-windows-host-rancher-2-1/11941
**Category:** General
**Created:** [October 4, 2018, 9:49am UTC](https://forums.suse.com/t/adding-windows-host-rancher-2-1/11941 "2018-10-04T09:49:09Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![tan-tan-kanarek](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/tan-tan-kanarek/32/4507_2.png) [@tan-tan-kanarek](https://forums.suse.com/u/tan-tan-kanarek)
#### Post date: [October 4, 2018, 9:49am UTC](https://forums.suse.com/t/adding-windows-host-rancher-2-1/11941/1 "2018-10-04T09:49:09Z")

</div>

Hi,  
I installed Rancher v2.1.0-rc9 because I want to learn how the experimental support for Windows nodes will work in version 2.1.  
I couldn’t find any way to define windows AMI when configuring EC2 cluster.  
Is there any documentation or tutorial of this new experimental feature?

---

<div class="post-metadata">

### Author: ![tan-tan-kanarek](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/tan-tan-kanarek/32/4507_2.png) [@tan-tan-kanarek](https://forums.suse.com/u/tan-tan-kanarek)
#### Post date: [October 7, 2018, 6:23pm UTC](https://forums.suse.com/t/adding-windows-host-rancher-2-1/11941/3 "2018-10-07T18:23:49Z")

</div>

Found it: [https://rancher.com/docs//rancher/v2.x/en/cluster-provisioning/rke-clusters/windows-clusters/](https://rancher.com/docs//rancher/v2.x/en/cluster-provisioning/rke-clusters/windows-clusters/)

So my next question would be, is there any plan to support Hybrid cluster of Windows and Linux in [Rancher Quickstart](https://github.com/rancher/quickstart) for AWS?

---

<div class="post-metadata">

### Author: ![tan-tan-kanarek](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/tan-tan-kanarek/32/4507_2.png) [@tan-tan-kanarek](https://forums.suse.com/u/tan-tan-kanarek)
#### Post date: [October 8, 2018, 9:32am UTC](https://forums.suse.com/t/adding-windows-host-rancher-2-1/11941/4 "2018-10-08T09:32:59Z")

</div>

rancher/rancher-agent:v2.1.0-nanoserver-1803 is not released for some reason.  
I used rancher/rancher-agent:v2.1.0- **rc8** -nanoserver-1803 instead.

---

<div class="post-metadata">

### Author: ![tan-tan-kanarek](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/tan-tan-kanarek/32/4507_2.png) [@tan-tan-kanarek](https://forums.suse.com/u/tan-tan-kanarek)
#### Post date: [October 17, 2018, 10:47am UTC](https://forums.suse.com/t/adding-windows-host-rancher-2-1/11941/5 "2018-10-17T10:47:28Z")

</div>

When trying to add new windows workers I get repeatedly the following message:  
INFO[2569] Starting kubelet …  
INFO[2570] …, overwriting flanneld config  
INFO[2571] …, overwriting cni config  
INFO[2572] …  
INFO[2573] …  
INFO[2574] …  
INFO[2575] …  
INFO[2576] …  
INFO[2577] …  
WARN[2578] … FAILED, agent retry  
WARN[2579] This connection try to touch proxy again: PowerShell process is going to retry  
INFO[2580] Connecting to proxy wss://[my ip]/v3/connect with token [my token]  
INFO[2581] Starting kubelet …  
INFO[2582] …, overwriting flanneld config  
INFO[2583] …, overwriting cni config  
INFO[2584] …  
INFO[2585] …  
INFO[2586] …  
INFO[2587] …  
INFO[2588] …  
INFO[2589] …  
WARN[2590] … FAILED, agent retry

The machine is not able to register.

From the log:  
I1017 12:24:48.691309 1960 aws.go:1025] Building AWS cloudprovider  
I1017 12:24:48.693311 1960 aws.go:987] Zone not specified in configuration file; querying AWS metadata service  
E1017 12:24:48.812331 1960 tags.go:94] Tag “KubernetesCluster” nor “[kubernetes.io/cluster/](http://kubernetes.io/cluster/)…” not found; Kubernetes may behave unexpectedly.  
F1017 12:24:48.813332 1960 server.go:262] failed to run Kubelet: could not init cloud provider “aws”: AWS cloud failed to find ClusterID

I tried to add -label [kubernetes.io/cluster/c-nqw2s=shared](http://kubernetes.io/cluster/c-nqw2s=shared) to the command, it didn’t help.  
Any idea how to add that label?

Did I miss anything?

---

<div class="post-metadata">

### Author: ![tan-tan-kanarek](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/tan-tan-kanarek/32/4507_2.png) [@tan-tan-kanarek](https://forums.suse.com/u/tan-tan-kanarek)
#### Post date: [October 17, 2018, 12:39pm UTC](https://forums.suse.com/t/adding-windows-host-rancher-2-1/11941/6 "2018-10-17T12:39:58Z")

</div>

Solved, had to add the tag to the AWS instance: [kubernetes.io/cluster/c-nqw2s=shared](http://kubernetes.io/cluster/c-nqw2s=shared)
