# After add catalog rancher cannot start

**URL:** <https://forums.suse.com/t/after-add-catalog-rancher-cannot-start/20654>\
**Category:** SUSE Rancher Prime\
**Created:** [July 5, 2021, 9:35pm UTC](https://forums.suse.com/t/after-add-catalog-rancher-cannot-start/20654 "2021-07-05T21:35:50Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![agferronato](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/agferronato/32/7744_2.png) [@agferronato](https://forums.suse.com/u/agferronato)\
**Post date:** [July 5, 2021, 9:35pm UTC](https://forums.suse.com/t/after-add-catalog-rancher-cannot-start/20654/1 "2021-07-05T21:35:51Z")

</div>

Hi,  
After i added a catalog to rancher, it’s broken, and now i receive the following error:

> 2021/07/05 21:27:35 [ERROR] failed to start cluster controllers c-8vm88: context canceled  
> 2021/07/05 21:27:45 [ERROR] error syncing ‘rancher-partner-charts’: handler helm-clusterrepo-ensure: git -C /var/lib/rancher-data/local-catalogs/v2/rancher-partner-charts/8f17acdce9bffd6e05a58a3798840e408c4ea71783381ecd2e9af30baad65974 reset --hard FETCH\_HEAD error: exit status 128, detail: fatal: Unable to create ‘/var/lib/rancher-data/local-catalogs/v2/rancher-partner-charts/8f17acdce9bffd6e05a58a3798840e408c4ea71783381ecd2e9af30baad65974/.git/index.lock’: File exists.
> 
> Another git process seems to be running in this repository, e.g.  
> an editor opened by ‘git commit’. Please make sure all processes  
> are terminated then try again. If it still fails, a git process  
> may have crashed in this repository earlier:  
> remove the file manually to continue.  
> , handler helm-clusterrepo-download: git -C /var/lib/rancher-data/local-catalogs/v2/rancher-partner-charts/8f17acdce9bffd6e05a58a3798840e408c4ea71783381ecd2e9af30baad65974 reset --hard HEAD error: exit status 128, detail: fatal: Unable to create ‘/var/lib/rancher-data/local-catalogs/v2/rancher-partner-charts/8f17acdce9bffd6e05a58a3798840e408c4ea71783381ecd2e9af30baad65974/.git/index.lock’: File exists.
> 
> Another git process seems to be running in this repository, e.g.  
> an editor opened by ‘git commit’. Please make sure all processes  
> are terminated then try again. If it still fails, a git process  
> may have crashed in this repository earlier:  
> remove the file manually to continue.  
> , requeuing  
> 2021/07/05 21:27:47 [ERROR] error syncing ‘rancher-charts’: handler helm-clusterrepo-ensure: git -C /var/lib/rancher-data/local-catalogs/v2/rancher-charts/4b40cac650031b74776e87c1a726b0484d0877c3ec137da0872547ff9b73a721 reset --hard FETCH\_HEAD error: exit status 128, detail: fatal: Unable to create ‘/var/lib/rancher-data/local-catalogs/v2/rancher-charts/4b40cac650031b74776e87c1a726b0484d0877c3ec137da0872547ff9b73a721/.git/index.lock’: File exists.
> 
> Another git process seems to be running in this repository, e.g.  
> an editor opened by ‘git commit’. Please make sure all processes  
> are terminated then try again. If it still fails, a git process  
> may have crashed in this repository earlier:  
> remove the file manually to continue.  
> , handler helm-clusterrepo-download: git -C /var/lib/rancher-data/local-catalogs/v2/rancher-charts/4b40cac650031b74776e87c1a726b0484d0877c3ec137da0872547ff9b73a721 reset --hard HEAD error: exit status 128, detail: fatal: Unable to create ‘/var/lib/rancher-data/local-catalogs/v2/rancher-charts/4b40cac650031b74776e87c1a726b0484d0877c3ec137da0872547ff9b73a721/.git/index.lock’: File exists.
> 
> Another git process seems to be running in this repository, e.g.  
> an editor opened by ‘git commit’. Please make sure all processes  
> are terminated then try again. If it still fails, a git process  
> may have crashed in this repository earlier:  
> remove the file manually to continue.  
> , requeuing  
> W0705 21:28:52.064373 26 watcher.go:207] watch chan error: etcdserver: mvcc: required revision has been compacted  
> 2021-07-05 21:28:54.625828 I | mvcc: store.index: compact 29007475  
> 2021-07-05 21:28:55.041027 I | mvcc: finished scheduled compaction at 29007475 (took 404.107797ms)  
> 2021/07/05 21:29:32 [INFO] Stopping cluster agent for c-8vm88  
> 2021/07/05 21:29:32 [ERROR] failed to start cluster controllers c-8vm88: context canceled  
> 2021/07/05 21:29:42 [ERROR] error syncing ‘c-8vm88’: handler cluster-deploy: Get “[https://10.100.0.1:443/apis/apps/v1/namespaces/cattle-system/daemonsets/cattle-node-agent](https://10.100.0.1:443/apis/apps/v1/namespaces/cattle-system/daemonsets/cattle-node-agent)”: waiting for cluster [c-8vm88] agent to connect, requeuing

Rancher 2.5.8

I cannot remove the catalog or enter at rancher interface, i create a backup and try to update to rancher 2.5.9, but the errors persist.

Thanks

---

<div class="post-metadata">

**Author:** ![ygi](https://avatars.discourse-cdn.com/v4/letter/y/ba8739/32.png) [@ygi](https://forums.suse.com/u/ygi)\
**Post date:** [September 28, 2021, 6:29am UTC](https://forums.suse.com/t/after-add-catalog-rancher-cannot-start/20654/2 "2021-09-28T06:29:42Z")

</div>

Hello,  
Did you solve your issue? I get the same by adding a catalog in cluster scope, Rancher 2.5.8 too.  
Thanks

---

<div class="post-metadata">

**Author:** ![adampl](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/adampl/32/4182_2.png) [@adampl](https://forums.suse.com/u/adampl)\
**Post date:** [November 22, 2021, 1:58pm UTC](https://forums.suse.com/t/after-add-catalog-rancher-cannot-start/20654/3 "2021-11-22T13:58:13Z")

</div>

I’m struggling with the same issue! Rancher keeps restarting, it makes it totally useless ☹

Also v2.5.8

---

<div class="post-metadata">

**Author:** ![abhishekk8s](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/abhishekk8s/32/8380_2.png) [@abhishekk8s](https://forums.suse.com/u/abhishekk8s)\
**Post date:** [December 13, 2021, 11:16am UTC](https://forums.suse.com/t/after-add-catalog-rancher-cannot-start/20654/4 "2021-12-13T11:16:43Z")

</div>

To fix this, just run below commands on your rancher node where teh docker is running  
docker exec -it \<container\_ID\> bash  
Then inside the running rancher docker, remove the specific .lock file which is shown in error and it should work fine

### 

cd ‘/var/lib/rancher-data/local-catalogs/v2/rancher-charts/4b40cac650031b74776e87c1a726b0484d0877c3ec137da0872547ff9b73a721/.git"  
then rm index.lock

#### 

after this, no error are cropping up in the racnher running docker.

---

<div class="post-metadata">

**Author:** ![Wayne\_Harbart](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/wayne_harbart/32/10991_2.png) [@Wayne\_Harbart](https://forums.suse.com/u/Wayne_Harbart)\
**Post date:** [February 22, 2024, 12:13pm UTC](https://forums.suse.com/t/after-add-catalog-rancher-cannot-start/20654/5 "2024-02-22T12:13:20Z")

</div>

Thank you 3 year old post for saving my morning. Simple problems can be a big deal when you are over tired.
