# Autoyast

**URL:** <https://forums.suse.com/t/autoyast/29681>\
**Category:** SLED Configure-Administer\
**Created:** [April 19, 2017, 10:42pm UTC](https://forums.suse.com/t/autoyast/29681 "2017-04-19T22:42:32Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![eharrison](https://avatars.discourse-cdn.com/v4/letter/e/e19b73/32.png) [@eharrison](https://forums.suse.com/u/eharrison)\
**Post date:** [April 19, 2017, 10:42pm UTC](https://forums.suse.com/t/autoyast/29681/1 "2017-04-19T22:42:32Z")

</div>

Hello all,  
Im new you suse linux but not linux as a whole. I am trying to use autoyast to install SLED 11 sp3. I have set up a thumb drive with grub2 and i am able to pass in my paraleter to the linux kernel

linux /boot/linux root=(hd0,msdos1) textmode=1 autoyast=file://autoinst.xml install=hd://sda1/boot/SLED-11-SP3-i586/  
initrd /boot/initrd  
boot

the installation media mounts and goes through its normal HW probe but then throws the following error

The xml parser reported an error while parsing the autoyast profile. the error is a directoryDocument is empty  
start tag expected, ‘\<’ not found.

How do I get the profile to load to autoinstall the os?  
any help would be greatly appreciated.

---

<div class="post-metadata">

**Author:** ![smflood](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/smflood/32/10576_2.png) [@smflood](https://forums.suse.com/u/smflood)\
**Post date:** [April 19, 2017, 11:11pm UTC](https://forums.suse.com/t/autoyast/29681/2 "2017-04-19T23:11:15Z")

</div>

eharrison Wrote in message:  
[color=blue]

> Im new you suse linux but not linux as a whole. I am trying to use  
> autoyast to install SLED 11 sp3. I have set up a thumb drive with grub2  
> and i am able to pass in my paraleter to the linux kernel
> 
> linux /boot/linux root=(hd0,msdos1) textmode=1  
> autoyast=file://autoinst.xml install=hd://sda1/boot/SLED-11-SP3-i586/  
> initrd /boot/initrd  
> boot
> 
> the installation media mounts and goes through its normal HW probe but  
> then throws the following error
> 
> The xml parser reported an error while parsing the autoyast profile.  
> the error is a directoryDocument is empty  
> start tag expected, ‘\<’ not found.
> 
> How do I get the profile to load to autoinstall the os?  
> any help would be greatly appreciated.[/color]

Try with “autoyast=file:///autoinst.xml …” i.e. with three  
forward slash (/) characters.

## HTH.

Simon Flood  
SUSE Knowledge Partner

----Android NewsGroup Reader----  
[http://usenet.sinaapp.com/](http://usenet.sinaapp.com/)

---

<div class="post-metadata">

**Author:** ![eharrison](https://avatars.discourse-cdn.com/v4/letter/e/e19b73/32.png) [@eharrison](https://forums.suse.com/u/eharrison)\
**Post date:** [April 19, 2017, 11:29pm UTC](https://forums.suse.com/t/autoyast/29681/3 "2017-04-19T23:29:15Z")

</div>

[QUOTE=smflood;37521]eharrison Wrote in message:  
[color=blue]

> Im new you suse linux but not linux as a whole. I am trying to use  
> autoyast to install SLED 11 sp3. I have set up a thumb drive with grub2  
> and i am able to pass in my paraleter to the linux kernel
> 
> linux /boot/linux root=(hd0,msdos1) textmode=1  
> autoyast=file://autoinst.xml install=hd://sda1/boot/SLED-11-SP3-i586/  
> initrd /boot/initrd  
> boot
> 
> the installation media mounts and goes through its normal HW probe but  
> then throws the following error
> 
> The xml parser reported an error while parsing the autoyast profile.  
> the error is a directoryDocument is empty  
> start tag expected, ‘\<’ not found.
> 
> How do I get the profile to load to autoinstall the os?  
> any help would be greatly appreciated.[/color]

Try with “autoyast=file:///autoinst.xml …” i.e. with three  
forward slash (/) characters.

## HTH.

Simon Flood  
SUSE Knowledge Partner

----Android NewsGroup Reader----  
[http://usenet.sinaapp.com/](http://usenet.sinaapp.com/)[/QUOTE]

thanks for the reply. Adding the additional / produced the following error

An error Occured while fetching the profile:  
reading file on /var/adm/mount//autoinst.xml failed  
reading file on /autoinst.xml failed  
reading a file on CD failed. Path : /tmp/yast2-03322-4hz1gz/tmp\_mount//autoinst.xml.

I looks like it is trying a couple of directories to find the xml file but no luck. Any thoughts?

---

<div class="post-metadata">

**Author:** ![ab1](https://avatars.discourse-cdn.com/v4/letter/a/d2c977/32.png) [@ab1](https://forums.suse.com/u/ab1)\
**Post date:** [April 20, 2017, 12:06am UTC](https://forums.suse.com/t/autoyast/29681/4 "2017-04-20T00:06:43Z")

</div>

When you’re in the system (after seeing the error) do you see the path  
where that file is? Maybe it has a difference device which you can pass  
in, but right now it seems you and Grub disagree on how to reach the USB  
stick once running the installer.

Seeing the output from the ‘mount’ command would be a fair starting point,  
in my opinion.

–  
Good luck.

If you find this post helpful and are logged into the web interface,  
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the  
forum as I do not use the web interface often.

---

<div class="post-metadata">

**Author:** ![smflood](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/smflood/32/10576_2.png) [@smflood](https://forums.suse.com/u/smflood)\
**Post date:** [April 20, 2017, 12:51pm UTC](https://forums.suse.com/t/autoyast/29681/5 "2017-04-20T12:51:27Z")

</div>

On 19/04/17 21:34, eharrison wrote:  
[color=blue]

> thanks for the reply. Adding the additional / produced the following  
> error
> 
> An error Occured while fetching the profile:  
> reading file on /var/adm/mount//autoinst.xml failed  
> reading file on /autoinst.xml failed  
> reading a file on CD failed. Path :  
> /tmp/yast2-03322-4hz1gz/tmp\_mount//autoinst.xml.
> 
> I looks like it is trying a couple of directories to find the xml file  
> but no luck. Any thoughts?[/color]

How did you create the autoinst.xml file? Can you perhaps post the  
contents, or at least the first few lines (wrapped in [CODE] tags)?

## HTH.

Simon  
SUSE Knowledge Partner

* * *

## If you find this post helpful and are logged into the web interface, please show your appreciation and click on the star below. Thanks.

---

<div class="post-metadata">

**Author:** ![eharrison](https://avatars.discourse-cdn.com/v4/letter/e/e19b73/32.png) [@eharrison](https://forums.suse.com/u/eharrison)\
**Post date:** [April 20, 2017, 8:11pm UTC](https://forums.suse.com/t/autoyast/29681/6 "2017-04-20T20:11:58Z")

</div>

[QUOTE=smflood;37533]On 19/04/17 21:34, eharrison wrote:  
[color=blue]

> thanks for the reply. Adding the additional / produced the following  
> error
> 
> An error Occured while fetching the profile:  
> reading file on /var/adm/mount//autoinst.xml failed  
> reading file on /autoinst.xml failed  
> reading a file on CD failed. Path :  
> /tmp/yast2-03322-4hz1gz/tmp\_mount//autoinst.xml.
> 
> I looks like it is trying a couple of directories to find the xml file  
> but no luck. Any thoughts?[/color]

How did you create the autoinst.xml file? Can you perhaps post the  
contents, or at least the first few lines (wrapped in [CODE] tags)?

## HTH.

Simon  
SUSE Knowledge Partner

* * *

If you find this post helpful and are logged into the web interface,  
please show your appreciation and click on the star below. Thanks.  
------------------------------------------------------------------------[/QUOTE]  
I create the autoinst.xml from the command line of a SUSE linux machine  
yast2 clone\_system  
here is the xml file. i did run it through xmllint and no errors were returned.

[CODE]  
  
\<add\_on\_products config:type=“list”/\>  
  
  
  
true  
SUSE Linux Enterprise Desktop 11 SP3 - 3.0.101-0.8  
\<generic\_mbr\>true\</generic\_mbr\>  
(hd0,0)/message  
\<lines\_cache\_id\>4\</lines\_cache\_id\>  
2  
  
\<initrd\_modules config:type=“list”\>  
\<initrd\_module\>  
ahci  
\</initrd\_module\>  
\</initrd\_modules\>  
\<loader\_type\>grub\</loader\_type\>  
  
  
resume=/dev/sda2 splash=silent ksdevice=bootif text showopts  
(hd0,0)/vmlinuz-3.0.101-0.8-pae  
1  
(hd0,0)/initrd-3.0.101-0.8-pae  
\<lines\_cache\_id\>0\</lines\_cache\_id\>  
SUSE Linux Enterprise Desktop 11 SP3 - 3.0.101-0.8  
\<original\_name\>linux\</original\_name\>  
image  
  
  
showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max\_cstate=1 nomodeset x11failsafe  
(hd0,0)/vmlinuz-3.0.101-0.8-pae  
(hd0,0)/initrd-3.0.101-0.8-pae  
\<lines\_cache\_id\>1\</lines\_cache\_id\>  
Failsafe – SUSE Linux Enterprise Desktop 11 SP3 - 3.0.101-0.8  
\<original\_name\>failsafe\</original\_name\>  
image  
  
  
resume=/dev/sda2 splash=silent ksdevice=bootif text showopts  
(hd0,0)/vmlinuz-3.0.76-0.11-pae  
(hd0,0)/initrd-3.0.76-0.11-pae  
\<lines\_cache\_id\>2\</lines\_cache\_id\>  
SUSE Linux Enterprise Desktop 11 SP3 - 3.0.76-0.11  
\<original\_name\>linux\</original\_name\>  
/dev/VolGroup00/LogVol00  
image  
0x314  
  
  
showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max\_cstate=1 nomodeset x11failsafe  
(hd0,0)/vmlinuz-3.0.76-0.11-pae  
(hd0,0)/initrd-3.0.76-0.11-pae  
\<lines\_cache\_id\>3\</lines\_cache\_id\>  
Failsafe – SUSE Linux Enterprise Desktop 11 SP3 - 3.0.76-0.11  
\<original\_name\>failsafe\</original\_name\>  
/dev/VolGroup00/LogVol00  
image  
0x314  
  
  
  
\<deploy\_image\>  
\<image\_installation config:type=“boolean”\>false\</image\_installation\>  
\</deploy\_image\>  
  
\<FW\_ALLOW\_FW\_BROADCAST\_DMZ\>no\</FW\_ALLOW\_FW\_BROADCAST\_DMZ\>  
\<FW\_ALLOW\_FW\_BROADCAST\_EXT\>no\</FW\_ALLOW\_FW\_BROADCAST\_EXT\>  
\<FW\_ALLOW\_FW\_BROADCAST\_INT\>no\</FW\_ALLOW\_FW\_BROADCAST\_INT\>  
\<FW\_CONFIGURATIONS\_DMZ\>\</FW\_CONFIGURATIONS\_DMZ\>  
\<FW\_CONFIGURATIONS\_EXT\>\</FW\_CONFIGURATIONS\_EXT\>  
\<FW\_CONFIGURATIONS\_INT\>\</FW\_CONFIGURATIONS\_INT\>  
\<FW\_DEV\_DMZ\>\</FW\_DEV\_DMZ\>  
\<FW\_DEV\_EXT\>\</FW\_DEV\_EXT\>  
\<FW\_DEV\_INT\>\</FW\_DEV\_INT\>  
\<FW\_FORWARD\_ALWAYS\_INOUT\_DEV\>\</FW\_FORWARD\_ALWAYS\_INOUT\_DEV\>  
\<FW\_FORWARD\_MASQ\>\</FW\_FORWARD\_MASQ\>  
\<FW\_IGNORE\_FW\_BROADCAST\_DMZ\>no\</FW\_IGNORE\_FW\_BROADCAST\_DMZ\>  
\<FW\_IGNORE\_FW\_BROADCAST\_EXT\>yes\</FW\_IGNORE\_FW\_BROADCAST\_EXT\>  
\<FW\_IGNORE\_FW\_BROADCAST\_INT\>no\</FW\_IGNORE\_FW\_BROADCAST\_INT\>  
\<FW\_IPSEC\_TRUST\>no\</FW\_IPSEC\_TRUST\>  
\<FW\_LOAD\_MODULES\>nf\_conntrack\_netbios\_ns\</FW\_LOAD\_MODULES\>  
\<FW\_LOG\_ACCEPT\_ALL\>no\</FW\_LOG\_ACCEPT\_ALL\>  
\<FW\_LOG\_ACCEPT\_CRIT\>yes\</FW\_LOG\_ACCEPT\_CRIT\>  
\<FW\_LOG\_DROP\_ALL\>no\</FW\_LOG\_DROP\_ALL\>  
\<FW\_LOG\_DROP\_CRIT\>yes\</FW\_LOG\_DROP\_CRIT\>  
\<FW\_MASQUERADE\>no\</FW\_MASQUERADE\>  
\<FW\_PROTECT\_FROM\_INT\>no\</FW\_PROTECT\_FROM\_INT\>  
\<FW\_ROUTE\>no\</FW\_ROUTE\>  
\<FW\_SERVICES\_ACCEPT\_DMZ\>\</FW\_SERVICES\_ACCEPT\_DMZ\>  
\<FW\_SERVICES\_ACCEPT\_EXT\>\</FW\_SERVICES\_ACCEPT\_EXT\>  
\<FW\_SERVICES\_ACCEPT\_INT\>\</FW\_SERVICES\_ACCEPT\_INT\>  
\<FW\_SERVICES\_ACCEPT\_RELATED\_DMZ\>\</FW\_SERVICES\_ACCEPT\_RELATED\_DMZ\>  
\<FW\_SERVICES\_ACCEPT\_RELATED\_EXT\>\</FW\_SERVICES\_ACCEPT\_RELATED\_EXT\>  
\<FW\_SERVICES\_ACCEPT\_RELATED\_INT\>\</FW\_SERVICES\_ACCEPT\_RELATED\_INT\>  
\<FW\_SERVICES\_DMZ\_IP\>\</FW\_SERVICES\_DMZ\_IP\>  
\<FW\_SERVICES\_DMZ\_RPC\>\</FW\_SERVICES\_DMZ\_RPC\>  
\<FW\_SERVICES\_DMZ\_TCP\>\</FW\_SERVICES\_DMZ\_TCP\>  
\<FW\_SERVICES\_DMZ\_UDP\>\</FW\_SERVICES\_DMZ\_UDP\>  
\<FW\_SERVICES\_EXT\_IP\>\</FW\_SERVICES\_EXT\_IP\>  
\<FW\_SERVICES\_EXT\_RPC\>\</FW\_SERVICES\_EXT\_RPC\>  
\<FW\_SERVICES\_EXT\_TCP\>\</FW\_SERVICES\_EXT\_TCP\>  
\<FW\_SERVICES\_EXT\_UDP\>\</FW\_SERVICES\_EXT\_UDP\>  
\<FW\_SERVICES\_INT\_IP\>\</FW\_SERVICES\_INT\_IP\>  
\<FW\_SERVICES\_INT\_RPC\>\</FW\_SERVICES\_INT\_RPC\>  
\<FW\_SERVICES\_INT\_TCP\>\</FW\_SERVICES\_INT\_TCP\>  
\<FW\_SERVICES\_INT\_UDP\>\</FW\_SERVICES\_INT\_UDP\>  
\<enable\_firewall config:type=“boolean”\>false\</enable\_firewall\>  
\<start\_firewall config:type=“boolean”\>false\</start\_firewall\>  
  
  
  
  
false  
  
  
none  
  
  
  
\<accept\_file\_without\_checksum config:type=“boolean”\>true\</accept\_file\_without\_checksum\>  
\<accept\_non\_trusted\_gpg\_key config:type=“boolean”\>true\</accept\_non\_trusted\_gpg\_key\>  
\<accept\_unknown\_gpg\_key config:type=“boolean”\>true\</accept\_unknown\_gpg\_key\>  
\<accept\_unsigned\_file config:type=“boolean”\>true\</accept\_unsigned\_file\>  
\<accept\_verification\_failed config:type=“boolean”\>false\</accept\_verification\_failed\>  
\<import\_gpg\_key config:type=“boolean”\>true\</import\_gpg\_key\>  
  
  
  
  
  
true  
1001  
\<group\_password\>x\</group\_password\>  
puppet  
puppet  
  
  
true  
100  
\<group\_password\>x\</group\_password\>  
users  
  
  
  
true  
1000  
\<group\_password\>x\</group\_password\>  
pos  
pos  
  
  
true  
19  
\<group\_password\>x\</group\_password\>  
floppy  
  
  
  
true  
1  
\<group\_password\>x\</group\_password\>  
bin  
daemon  
  
  
true  
41  
\<group\_password\>x\</group\_password\>  
xok  
  
  
  
true  
65533  
\<group\_password\>x\</group\_password\>  
nobody  
  
  
  
true  
43  
\<group\_password\>x\</group\_password\>  
modem  
  
  
  
true  
5  
\<group\_password\>x\</group\_password\>  
tty  
  
  
  
true  
7  
\<group\_password\>x\</group\_password\>  
lp  
  
  
  
true  
104  
\<group\_password\>!\</group\_password\>  
uuidd  
  
  
  
true  
51  
\<group\_password\>!\</group\_password\>  
postfix  
  
  
  
true  
65534  
\<group\_password\>x\</group\_password\>  
nogroup  
nobody  
  
  
true  
101  
\<group\_password\>!\</group\_password\>  
messagebus  
  
  
  
true  
59  
\<group\_password\>!\</group\_password\>  
maildrop  
  
  
  
true  
33  
\<group\_password\>x\</group\_password\>  
video  
  
  
  
true  
3  
\<group\_password\>x\</group\_password\>  
sys  
  
  
  
true  
15  
\<group\_password\>x\</group\_password\>  
shadow  
  
  
  
true  
20  
\<group\_password\>x\</group\_password\>  
cdrom  
  
  
  
true  
21  
\<group\_password\>x\</group\_password\>  
console  
  
  
  
true  
42  
\<group\_password\>x\</group\_password\>  
trusted  
  
  
  
true  
102  
\<group\_password\>!\</group\_password\>  
haldaemon  
  
  
  
true  
16  
\<group\_password\>x\</group\_password\>  
dialout  
  
  
  
true  
105  
\<group\_password\>!\</group\_password\>  
polkituser  
  
  
  
true  
10  
\<group\_password\>x\</group\_password\>  
wheel  
  
  
  
true  
107  
\<group\_password\>!\</group\_password\>  
pulse  
  
  
  
true  
8  
\<group\_password\>x\</group\_password\>  
www  
  
  
  
true  
40  
\<group\_password\>x\</group\_password\>  
games  
  
  
  
true  
6  
\<group\_password\>x\</group\_password\>  
disk  
  
  
  
true  
17  
\<group\_password\>x\</group\_password\>  
audio  
pulse  
  
  
true  
49  
\<group\_password\>x\</group\_password\>  
ftp  
  
  
  
true  
109  
\<group\_password\>!\</group\_password\>  
suse-ncc  
  
  
  
true  
103  
\<group\_password\>!\</group\_password\>  
tape  
  
  
  
true  
25  
\<group\_password\>!\</group\_password\>  
at  
  
  
  
true  
9  
\<group\_password\>x\</group\_password\>  
kmem  
  
  
  
true  
32  
\<group\_password\>x\</group\_password\>  
public  
  
  
  
true  
12  
\<group\_password\>x\</group\_password\>  
mail  
  
  
  
true  
0  
\<group\_password\>x\</group\_password\>  
root  
  
  
  
true  
2  
\<group\_password\>x\</group\_password\>  
daemon  
  
  
  
true  
106  
\<group\_password\>!\</group\_password\>  
ntp  
  
  
  
true  
14  
\<group\_password\>x\</group\_password\>  
uucp  
  
  
  
true  
108  
\<group\_password\>!\</group\_password\>  
pulse-access  
  
  
  
true  
62  
\<group\_password\>x\</group\_password\>  
man  
  
  
  
true  
22  
\<group\_password\>x\</group\_password\>  
utmp  
  
  
  
true  
13  
\<group\_password\>x\</group\_password\>  
news  
  
  
  
true  
65  
\<group\_password\>!\</group\_password\>  
sshd  
  
  
  
  
  
\<hosts\_entry\>  
\<host\_address\>10.50.48.66\</host\_address\>  
  
STORE\_SERVER  
puppet  
  
\</hosts\_entry\>  
\<hosts\_entry\>  
\<host\_address\>127.0.0.1\</host\_address\>  
  
localhost  
  
\</hosts\_entry\>  
\<hosts\_entry\>  
\<host\_address\>127.0.0.2\</host\_address\>  
  
  
\</hosts\_entry\>  
\<hosts\_entry\>  
\<host\_address\>::1\</host\_address\>  
  
localhost ipv6-localhost ipv6-loopback  
  
\</hosts\_entry\>  
\<hosts\_entry\>  
\<host\_address\>fe00::0\</host\_address\>  
  
ipv6-localnet  
  
\</hosts\_entry\>  
\<hosts\_entry\>  
\<host\_address\>ff00::0\</host\_address\>  
  
ipv6-mcastprefix  
  
\</hosts\_entry\>  
\<hosts\_entry\>  
\<host\_address\>ff02::1\</host\_address\>  
  
ipv6-allnodes  
  
\</hosts\_entry\>  
\<hosts\_entry\>  
\<host\_address\>ff02::2\</host\_address\>  
  
ipv6-allrouters  
  
\</hosts\_entry\>  
\<hosts\_entry\>  
\<host\_address\>ff02::3\</host\_address\>  
  
ipv6-allhosts  
  
\</hosts\_entry\>  
  
  
  
english-us  
  
  
en\_US  
en\_US  
  
\<login\_settings/\>  
  
\<dhcp\_options\>  
\<dhclient\_client\_id\>\</dhclient\_client\_id\>  
\<dhclient\_hostname\_option\>AUTO\</dhclient\_hostname\_option\>  
\</dhcp\_options\>  
  
\<dhcp\_hostname config:type=“boolean”\>true\</dhcp\_hostname\>  
[00802.retailoperations.urbanoutfitters.com](http://00802.retailoperations.urbanoutfitters.com)  
\<resolv\_conf\_policy\>auto\</resolv\_conf\_policy\>  
\<write\_hostname config:type=“boolean”\>true\</write\_hostname\>  
  
  
  
dhcp  
eth0  
Intel Ethernet controller  
auto  
no  
  
  
  
  
127.0.0.2  
255.0.0.0  
8  
  
  
127.255.255.255  
lo  
no  
127.0.0.1  
255.0.0.0  
127.0.0.0  
8  
auto  
no  
  
  
true  
  
\<ip\_forward config:type=“boolean”\>false\</ip\_forward\>  
  
  
  
\<ntp\_policy\>auto\</ntp\_policy\>  
  
  
10.1.1.30  
################################################################################

## /etc/ntp.conf

## 

## Sample NTP configuration file.

## See package ‘ntp-doc’ for documentation, Mini-HOWTO and FAQ.

## Copyright (c) 1998 S.u.S.E. GmbH Fuerth, Germany.

## 

## Author: Michael Andres, [ma@suse.de](mailto:ma@suse.de)

## Michael Skibbe, [mskibbe@suse.de](mailto:mskibbe@suse.de)

## 

################################################################################

## 

## Radio and modem clocks by convention have addresses in the

## form 127.127.t.u, where t is the clock type and u is a unit

## number in the range 0-3.

## 

## Most of these clocks require support in the form of a

## serial port or special bus peripheral. The particular

## device is normally specified by adding a soft link

## /dev/device-u to the particular hardware device involved,

## where u correspond to the unit number above.

## 

## Generic DCF77 clock on serial port (Conrad DCF77)

## Address: 127.127.8.u

## Serial Port: /dev/refclock-u

## 

## (create soft link /dev/refclock-0 to the particular ttyS?)

## 

# server 127.127.8.0 mode 5 prefer

## 

## Undisciplined Local Clock. This is a fake driver intended for backup

## and when no outside source of synchronized time is available.

## 
 server 10.1.1.31 server /var/lib/ntp/drift/ntp.drift ## ## Add external Servers using ## # rcntp addserver ## 
## 

## Miscellaneous stuff

## 
 driftfile /var/log/ntp # path for drift file logfile /etc/ntp.keys # alternate log file # logconfig =syncstatus + sysevents # logconfig =all
# statsdir /tmp/ # directory for statistics files

# filegen peerstats file peerstats type day enable

# filegen loopstats file loopstats type day enable

# filegen clockstats file clockstats type day enable

# 

# Authentication stuff

# 
 keys 1 # path for keys file trustedkey 1 # define trusted keys requestkey true true false true true 0 true true 0 true true 0 true true 0 3 Servebase.Pceft.PedFramework crda elo\_driver\_370 findutils-locate gconf2-branding-SLED ibm-java-i386-javacomm ibm-java-i386-jre javax-usb javax-usb-ri javax-usb-ri-linux libgio-fam toshiba-javapos toshiba-mus2.1\_up\_6149\_touch-bd3z2eUoFka82VBE70IVwA\_0002 toshiba-mus\_op-suse toshiba-poss-suse11-kmp-pae toshiba-sleep-prot-suse11-kmp-pae toshibaposs-gcc43 wireless-regdb x11-input-wacom yast2-trans-en\_US desktop-base documentation fonts x11 FZMingTiB FZSongTi IlmBase KhmerOS-fonts NetworkManager-kde4 NetworkManager-kde4-lang NetworkManager-kde4-libs NetworkManager-openvpn-kde4 NetworkManager-vpnc-kde4 OpenEXR alsa alsa-oss alsa-plugins alsa-utils aspell aspell-en avahi avahi-lang backup-manager backup-manager-lang baekmuk baekmuk-ttf bluez bluez-alsa bluez-gstreamer clucene-core cups cups-autoconfig cups-drivers dbus-1-python efont-unicode enchant enscript evolution-data-server evolution-data-server-lang facter flash-player freefont gnokii gnome-bluetooth gnome-bluetooth-lang gnome-docker gnome-menus gnome-menus-branding-SLED gnome-menus-lang gnome-phone-manager gnome-phone-manager-lang gnome-user-share gnome-user-share-lang gpgme gsynaptics gsynaptics-lang gtkspell gtkspell-lang gutenprint gvfs-backends hplip htdig ifnteuro intlfnts ispell-brazilian ispell-british ispell-catalan ispell-czech ispell-danish ispell-dutch ispell-finnish ispell-french ispell-german ispell-hungarian ispell-italian ispell-ngerman ispell-norsk ispell-polish ispell-portuguese ispell-russian ispell-slovak ispell-spanish ispell-swedish kbluetooth kde-susetranslations kde4-filesystem kde4-kgreeter-plugins kdebase4-SLED kdebase4-SLED-lang kdebase4-runtime kdebase4-runtime-branding-SLED kdebase4-workspace kdebase4-workspace-branding-SLED kdebase4-workspace-ksysguardd kdelibs3 kdelibs3-default-style kdelibs4 kdelibs4-branding-SLED kdelibs4-core kdepimlibs4 kdialog kdm kdm-branding-SLED kio\_sysinfo kio\_sysinfo-branding-SLED kscpm kwin libQtWebKit4 libakonadi4 libakonadiprotocolinternals1 libarchive2 libavahi-core5 libbluetooth3 libcanberra-gtk0 libcdio7 libcdio\_cdda0 libcdio\_paranoia0 libcroco-0\_6-3 libdaemon0 libdns\_sd libenchant1 libevoldap-2\_4-2 libexiv2-4 libgcj43 libgcj43-jar libgnome-bluetooth7 libgnome-menu2 libgnomesu libgnomesu-lang libgnomesu0 libgnutls26 libgpgme11 libgphoto2 libgphoto2-lang libgsf-1-114 libgweather libgweather-lang libgweather1 libical0 libicu libieee1284 libkde4 libkdecore4 libkdepimlibs4 libkexiv2-7 libknotificationitem-1-1 libkonq5 liblazy1 libldb1 libneon27 libphonon4 libpolkit-qt0 libpoppler5 libpq5 libproxy0 libqimageblitz4 libqt4-sql-postgresql libqt4-sql-sqlite libqt4-sql-unixODBC libraptor1 librasqal1 libredland0 libreoffice libreoffice-branding-SLED libreoffice-icon-themes libreoffice-writer librsvg librsync libsbc0 libsensors4 libslab-lang libslab0 libsoprano4 libsoup-2\_4-1 libstrigi0 libtevent0 libunique-1\_0-0 libxklavier15 novell-groupwise-gwclient novell-ldapext nss-mdns obex-data-server obexd oxygen-icon-theme oxygen-icon-theme-scalable pam-doc perl-Crypt-OpenSSL-RSA perl-IO-Socket-INET6 perl-IO-Socket-SSL perl-Mail-DKIM perl-MailTools perl-Net-DNS perl-Net-IP perl-Net-SSLeay perl-NetAddr-IP perl-Socket6 perl-libwww-perl perl-spamassassin phonon phonon-backend-gstreamer-0\_10 plasma-addons plasma-theme-aya plasmoid-networkmanagement plasmoid-quickaccess poppler-data poppler-tools puppet python-devel python-qt4 python-setuptools rdiff-backup re2c samba-client sane-backends sled-apps\_en-pdf sled-gnomeuser\_en-pdf sled-kdeuser\_en-pdf sled-manuals\_en sled-manuals\_en sled-security\_en-pdf soprano soprano-backend-redland spamassassin strigi sumf susehelp\_cz susehelp\_de susehelp\_es susehelp\_fr susehelp\_hu susehelp\_it tango-icon-theme ttf-alee unixODBC yast2-control-center-gnome yast2-gtk yast2-sound yast2-tv UTC America/New\_York 100 video,dialout /home -1 /bin/bash /etc/skel 022 true Puppet account 100 /home/puppet 99999 0 7 /bin/bash 1025 \* puppet true Zabbix account 100 /home/zabbix 99999 0 7 /bin/bash 1026 \* zabbix true POS account 100 /home/pos 99999 0 7 /bin/bash 1024 $2a$10$eUgHU18qTEFoTZITNaFBqOEHZJQWpZfpGojE6mX7kGaKEgMzYCIM6 pos true Games account 100 /var/games /bin/bash 12 \* games true bin 1 /bin /bin/bash 1 \* bin true dnsmasq 65534 /var/lib/empty 99999 0 7 /bin/false 103 \* dnsmasq true nobody 65533 /var/lib/nobody /bin/bash 65534 \* nobody true Printing daemon 7 /var/spool/lpd /bin/bash 4 \* lp true User for uuidd 104 /var/run/uuidd 99999 0 7 /bin/false 102 \* uuidd true Postfix Daemon 51 /var/spool/postfix 99999 0 7 /bin/false 51 \* postfix true Novell Customer Center User 109 /var/lib/YaST2/suse-ncc-fakehome 99999 0 7 /bin/bash 106 \* suse-ncc true FTP account 49 /srv/ftp /bin/bash 40 \* ftp true Batch jobs daemon 25 /var/spool/atjobs 99999 0 7 /bin/bash 25 \* at true root 0 /root 99999 0 7 /bin/bash 0 $2a$10$R7MrV2MxmWG0nZcRszMFzO2wTP3LA2PiPdoH0HqrXT1wkE0E4lO3m root true Mailer daemon 12 /var/spool/clientmqueue /bin/false 8 \* mail true Daemon 2 /sbin /bin/bash 2 \* daemon true NTP daemon 106 /var/lib/ntp 99999 0 7 /bin/false 74 \* ntp true Unix-to-Unix CoPy system 14 /etc/uucp /bin/bash 10 \* uucp true User for D-Bus 101 /var/run/dbus 0 7 /bin/false 100 \* messagebus true User for haldaemon 102 /var/run/hald 0 7 /bin/false 101 \* haldaemon true WWW daemon apache 8 /var/lib/wwwrun /bin/false 30 \* wwwrun true Manual pages viewer 62 /var/cache/man /bin/bash 13 \* man true PolicyKit 105 /var/run/PolicyKit 99999 0 7 /bin/false 104 \* polkituser true News system 13 /etc/news /bin/bash 9 \* news SSH daemon 65 /var/lib/sshd /bin/false 71 sshd true PulseAudio daemon 107 /var/lib/pulseaudio 99999 0 7 /bin/false 105 \* pulse 24 true 94 75 31 50 Unknown Unknown 800x600 (SVGA) [/CODE]

---

<div class="post-metadata">

**Author:** ![eharrison](https://avatars.discourse-cdn.com/v4/letter/e/e19b73/32.png) [@eharrison](https://forums.suse.com/u/eharrison)\
**Post date:** [April 20, 2017, 8:56pm UTC](https://forums.suse.com/t/autoyast/29681/7 "2017-04-20T20:56:41Z")

</div>

I really just looks like im not passing the correct location of the autoinst.xml to the linux kernel. is there any way for me to find it on the fly?

---

<div class="post-metadata">

**Author:** ![eharrison](https://avatars.discourse-cdn.com/v4/letter/e/e19b73/32.png) [@eharrison](https://forums.suse.com/u/eharrison)\
**Post date:** [April 20, 2017, 9:01pm UTC](https://forums.suse.com/t/autoyast/29681/8 "2017-04-20T21:01:13Z")

</div>

right, So the output from the mount command shows the autoinst file on the root of (hd0, msdos1)

---

<div class="post-metadata">

**Author:** ![eharrison](https://avatars.discourse-cdn.com/v4/letter/e/e19b73/32.png) [@eharrison](https://forums.suse.com/u/eharrison)\
**Post date:** [April 20, 2017, 10:14pm UTC](https://forums.suse.com/t/autoyast/29681/9 "2017-04-20T22:14:18Z")

</div>

so here something that is interesting. when i use autoyast=file:/// i get an error saying that autoyast cant find the file.
