# Beta-4 custom issue

**URL:** https://forums.suse.com/t/beta-4-custom-issue/10188
**Category:** Rancher 2.0 Tech Preview
**Created:** [April 27, 2018, 7:24am UTC](https://forums.suse.com/t/beta-4-custom-issue/10188 "2018-04-27T07:24:46Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![hwaastad](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/hwaastad/32/225_2.png) [@hwaastad](https://forums.suse.com/u/hwaastad)
#### Post date: [April 27, 2018, 7:24am UTC](https://forums.suse.com/t/beta-4-custom-issue/10188/1 "2018-04-27T07:24:46Z")

</div>

Hei,  
testing beta-4 and custom cluster type but cluster fails to come up messages like this is appearing

```
Waiting for API to be available; exit status 1, W0427 07:22:53.593633 7476 factory_object_mapping.go:423] Failed to download OpenAPI (the server has asked for the client to provide credentials), falling back to swagger error: You must be logged in to the server (Unauthorized)

```

Any workaround?

---

<div class="post-metadata">

### Author: ![hwaastad](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/hwaastad/32/225_2.png) [@hwaastad](https://forums.suse.com/u/hwaastad)
#### Post date: [April 30, 2018, 6:30pm UTC](https://forums.suse.com/t/beta-4-custom-issue/10188/2 "2018-04-30T18:30:37Z")

</div>

Answering myself:

1. docker rm -f $(docker ps -aq)
2. docker container prune
3. sudo rm -fr /etc/kubernetes/ /var/lib/etcd/ /etc/cni/ /opt/cni/ /var/run/calico/ (var/lib/etcd was the culprit)
