# Cannot add hosts from Azure

**URL:** <https://forums.suse.com/t/cannot-add-hosts-from-azure/4402>\
**Category:** Rancher 1.x\
**Created:** [October 24, 2016, 12:26am UTC](https://forums.suse.com/t/cannot-add-hosts-from-azure/4402 "2016-10-24T00:26:43Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![funkydorian](https://avatars.discourse-cdn.com/v4/letter/f/46a35a/32.png) [@funkydorian](https://forums.suse.com/u/funkydorian)\
**Post date:** [October 24, 2016, 12:26am UTC](https://forums.suse.com/t/cannot-add-hosts-from-azure/4402/1 "2016-10-24T00:26:43Z")

</div>

I already referred to the previously opened topic [Deploy Azure Hosts](http://forums.suse.com/t/deploy-azure-hosts/1442) but still i have errors.

I want to add hosts from Azure, here are the steps i did:

1- Create certificate with  
openssl req -new -x509 -key azure\_private.pem -out azure\_cacert.pem -days 3650  
openssl x509 -inform PEM -in azure\_cacert.pem -outform DER -out azure\_cert.cer

2- Upload the .cer file to Azure Classic referrring

> **[Upload an Azure Management API Certificate](https://docs.microsoft.com/en-us/azure/azure-api-management-certs)**
>
> Learn how to upload the Management API certificate for the Azure portal.

2- Rancher --\> Add Hosts --\> Azure  
paste subscription  
paster the Azure certificate (base64 azure\_cacert.pem |pbcopy)

3- I am having the following error:

Error with pre-create check: “Code: ForbiddenError, Message: The server failed to authenticate the request. Verify that the certificate is valid and is associated with this subscription.”
