# cannot register with service center

**URL:** <https://forums.suse.com/t/cannot-register-with-service-center/23461>\
**Category:** SLED Updates\
**Created:** [January 2, 2013, 4:02am UTC](https://forums.suse.com/t/cannot-register-with-service-center/23461 "2013-01-02T04:02:53Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![mutundis](https://avatars.discourse-cdn.com/v4/letter/m/c67d28/32.png) [@mutundis](https://forums.suse.com/u/mutundis)\
**Post date:** [January 2, 2013, 4:02am UTC](https://forums.suse.com/t/cannot-register-with-service-center/23461/1 "2013-01-02T04:02:53Z")

</div>

I just started using an HP workstation loaded with SLED 11 SP2. I want to enable the update repository which requires registration with the novell service center but I am unable to do this. Here’s what I do:

- From the Yast control centre I run as superuser “Online Update”. A initialization window reports that no update repository configured yet and offers the option of running “configuration workflow”
- running the “workflow” brings up the “Novell Customer Center Registration” dialog window
- Using default settings I click Next. This results in “An error occurred wile connecting to the server”, details of which are “ERROR: Failure when receiving data from the peer: (56)”.

I don’t know what to try next. The proxy is set correctly I believe.

Thanks for any help!

---

<div class="post-metadata">

**Author:** ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)\
**Post date:** [January 2, 2013, 5:21am UTC](https://forums.suse.com/t/cannot-register-with-service-center/23461/2 "2013-01-02T05:21:49Z")

</div>

> [@](#):
>
> On Wed 02 Jan 2013 02:04:02 AM CST, mutundis wrote:
> 
> I just started using an HP workstation loaded with SLED 11 SP2. I want  
> to enable the update repository which requires registration with the  
> novell service center but I am unable to do this. Here’s what I do:
> 
> - From the Yast control centre I run as superuser “Online Update”. A  
> initialization window reports that no update repository configured yet  
> and offers the option of running “configuration workflow”
> - running the “workflow” brings up the “Novell Customer Center  
> Registration” dialog window
> - Using default settings I click Next. This results in “An error  
> occurred wile connecting to the server”, details of which are “ERROR:  
> Failure when receiving data from the peer: (56)”.
> 
> I don’t know what to try next. The proxy is set correctly I believe.
> 
> Thanks for any help!

If your using a proxy, there are a few things to configure;

Your proxy should should accept Novell domain (or at least selected  
sites used like [nu.novell.com](http://nu.novell.com) and [secure.novell.com](http://secure.novell.com)) without  
authentication.

You need to populate proxy setting in YAST and to add two lines  
with your proxy information to /etc/profile, for example:

export http\_proxy=“[http://10.10.1.1:8081/](http://10.10.1.1:8081/)”  
export https\_proxy=“[https://10.10.1.1:8081/](https://10.10.1.1:8081/)”

As well as the /root/.curlrc

Then I would login to the NCC web page and delete the system and  
re-register it.

–  
Cheers Malcolm Â°Â¿Â° (Linux Counter #276890)  
openSUSE 12.2 (x86\_64) Kernel 3.4.11-2.16-desktop  
up 0:40, 2 users, load average: 0.14, 0.10, 0.07  
CPU IntelÂ® i5 CPU M520@2.40GHz | GPU IntelÂ® Ironlake Mobile

---

<div class="post-metadata">

**Author:** ![mutundis](https://avatars.discourse-cdn.com/v4/letter/m/c67d28/32.png) [@mutundis](https://forums.suse.com/u/mutundis)\
**Post date:** [January 3, 2013, 2:56am UTC](https://forums.suse.com/t/cannot-register-with-service-center/23461/3 "2013-01-03T02:56:57Z")

</div>

Thanks for this - yes it is indeed a proxy problem (I should have worked this out myself). I tried your suggestions but unfortunately we have a web proxy requiring authentication and I gather this makes things difficult. curl now works from the command line but the registration process still fails. I tried setting http\_proxy in the form [http://username:password@host:port/](http://username:password@host:port/) and then using the suse\_register command line program but still no go (Proxy Access Denied error about 1,000 times!). Is there any way to register through a proxy requiring authentication?

Thanks

---

<div class="post-metadata">

**Author:** ![malcolmlewis](https://sea2.discourse-cdn.com/flex022/user_avatar/forums.suse.com/malcolmlewis/32/11375_2.png) [@malcolmlewis](https://forums.suse.com/u/malcolmlewis)\
**Post date:** [January 3, 2013, 3:58pm UTC](https://forums.suse.com/t/cannot-register-with-service-center/23461/4 "2013-01-03T15:58:14Z")

</div>

> [@](#):
>
> On Thu 03 Jan 2013 01:04:02 AM CST, mutundis wrote:
> 
> Thanks for this - yes it is indeed a proxy problem (I should have worked  
> this out myself). I tried your suggestions but unfortunately we have a  
> web proxy requiring authentication and I gather this makes things  
> difficult. curl now works from the command line but the registration  
> process still fails. I tried setting http\_proxy in the form  
> [http://username:password@host:port/](http://username:password@host) and then using the suse\_register  
> command line program but still no go (Proxy Access Denied error about  
> 1,000 times!). Is there any way to register through a proxy requiring  
> authentication?
> 
> Thanks

Hi  
Are there any characters in your username or password that may need to  
be escaped?

Another thought since you indicate the command line curl is working, is  
to register via the command line;

```auto
suse_register -a regcode-sled=YourActivationCode -a email=YourEmailAddress -a moniker=YourHostname -L .suse_register.log
```

–  
Cheers Malcolm Â°Â¿Â° (Linux Counter #276890)  
openSUSE 12.2 (x86\_64) Kernel 3.4.11-2.16-desktop  
up 9:33, 3 users, load average: 0.03, 0.04, 0.05  
CPU IntelÂ® i5 CPU M520@2.40GHz | GPU IntelÂ® Ironlake Mobile

---

<div class="post-metadata">

**Author:** ![oz42](https://avatars.discourse-cdn.com/v4/letter/o/5e9695/32.png) [@oz42](https://forums.suse.com/u/oz42)\
**Post date:** [July 2, 2013, 5:38pm UTC](https://forums.suse.com/t/cannot-register-with-service-center/23461/5 "2013-07-02T17:38:01Z")

</div>

I have the same problem with SLES11SP2 and have just filed a bug report for suseRegister-1.4-1.24.1. Reason: suseRegister ignores the proxy credentials. When I run suse\_register, I get “HTTP/1.1 407 authenticationrequired”.
